#594 OSX Appearance: 1. Font size, 2. Menu disappears

None
closed
nobody
None
1
2013-06-02
2012-08-19
spieb
No

In OSX i set the font size in the appearance options to 9pt (where it says "ready" and "normal" mode ). However if i change the virtual desktop and then return, the font size is ignored and set to the standard value. I guess the window is redraw whenever i change the desktop.
Sometimes also the menu bar dissappears, but i haven't found a way to reproduce this, so i'll keep track of that.

Related

Bugs: #594

Discussion

<< < 1 2 3 > >> (Page 2 of 3)
  • Benito van der Zander

    What happens, if you remove the "menuBar()->hide();" call in line 1924
    of PDFDocument.cpp?

    Is there a difference between the Presentation and Full Screen mode of
    the pdf viewer? (i.e. how large is the window and is the menu visible there)

    And your link mentioned that double shortcut do not work there. Usually
    you can press "Ctrl+P, O" to select everything between matched
    parentheses, so that does not work on Mac?

    On 08/28/2012 11:29 PM, SourceForge.net wrote:

    Bugs

     
  • spieb

    spieb - 2012-08-30

    Im not really sure how this "Ctrl+P,O" selection works. If I press Ctrl+P on my windows machine it opens the print dialog, if I press Ctrl+O it opens the open dialog

     
  • Tim Hoffmann

    Tim Hoffmann - 2012-08-30

    It's "Ctrl+Shift+P,O":
    1. Place the cursor next to a bracket
    2. Press Ctrl+Shift+P
    3. Release all keys
    4. Press O

     
  • spieb

    spieb - 2012-08-30

    Unfortunately uncommenting the "menuBar()->hide();" line made no difference.

    Also I can confirm, the double shortcut doesn't work.

     
  • Tim Hoffmann

    Tim Hoffmann - 2012-09-12

    Chris, can you try rev. 3289, please?

     
  • spieb

    spieb - 2012-09-15

    Hi, sorry i wasn't at home, so i couldn't test.
    But no, unfortunately it still doesn't work.

     
  • Tim Hoffmann

    Tim Hoffmann - 2012-09-16

    Too bad. Now, I'm running out of ideas, and without actual access to an OSX system I cannot systematically test for tracking down the issue.

     
  • spieb

    spieb - 2012-09-16

    That's bad. I tried testing it myself, but i couldn't find an error either, plus the code is a little to complex to understand it quickly enough.

     
  • Dan

    Dan - 2012-11-01

    Dear spieb,

    I have been able to consistently reproduce the issue of the menu disappearing.

    To reproduce:
    Create a basic tex document.
    Compile the tex document.
    Open the resulting pdf in the internal viewer.
    Click the button to make the internal viewer it's own windows.
    Change focus back to the main window the menu is gone.
    Close the internal viewer windows, the menu remains gone.

    I did this on OS X 10.6.8 with the binary texstudio_2.5_svn3379.dmg.zip

    I looked around online and found that this is a known issue with Qt and OS X. I found a solution suggested here: http://stackoverflow.com/questions/7972721/menubar-issue-qt-4-7-4-on-mac-os-lion and in the Qt doucmentation http://doc.qt.nokia.com/4.7/qmainwindow.html#menuBar

    I downloaded the source file texstudio-2.5.tar.gz. Then tried compiling with BUILD.sh which wasn't working for me. It seemed to be confused by macports Qt and the system Qt. I have both installed.

    I finally cleaned and built with qmake from macports and make worked fine.

    From the suggestion, I modified two lines of code and it seems to do the trick, see attached patch. I'm not so familiar with Qt and I don't like leaving the new menubar pointer allocated without freeing it, which I guess could be freed in the configManager destructor, but this seems to work as a quick fix. I've only tested on OS X 10.6.8 with macports qt4-mac @4.8.3_1+quartz and poppler @0.20.5_0+qt4+quartz. I don't know if it will adversely effect windows or linux builds.

    Great project. I hope this fix helps.

    Thanks,
    Dan

     
    Attachments
  • spieb

    spieb - 2012-11-02

    Cool, thanks, maybe one of the main programmers will be able to fix it in a clean way. I hope they still read this old thread

     
  • Tim Hoffmann

    Tim Hoffmann - 2012-11-08

    Well, it's strange that this patch works. Essentially the same is done before calling setupMenus() for the first time:
    1. create a parentless MenuBar
    2. call setMenuBar() with it as argument.

    And then, setupMenus() is not called in the course of your example to reproduce the issue. So it cannot recreate the menubar in case it was lost for some reason.

    Anyway, could you please try if the following also works instead of your two lines:

    if (!configManager.menuParentsBar) {
        configManager.menuParentsBar = new DblClickMenuBar(0);
        setMenuBar(configManager.menuParentsBar)
    }
    

    or alternatively if it does not

    if (!configManager.menuParentsBar) {
        configManager.menuParentsBar = new DblClickMenuBar(0);
    }
    setMenuBar(configManager.menuParentsBar)
    

    Btw.: You don't have to worry about the pointer. setMenuBar() takes ownership of the menu and thus cares for deletion at the proper time.

     
    Last edit: Tim Hoffmann 2012-11-08
  • spieb

    spieb - 2012-11-11

    unfortunately neither of your methods worked for me. we're talking about texmaker.cpp, right?

     
  • Tim Hoffmann

    Tim Hoffmann - 2012-11-11

    Yes. Did Dan's patch work for you? Then well use this, although this recreates the menu bar, which should not be necessary in principle.

     
  • spieb

    spieb - 2012-11-12

    No, Dan's method didn't work either.
    Dan, do you have the source code and binary of a version that's working for you?

     
  • Tim Hoffmann

    Tim Hoffmann - 2012-11-18
    • summary: OSX Appearance --> OSX Appearance: 1. Font size, 2. Menu disappears
    • milestone: -->
     
  • Tim Hoffmann

    Tim Hoffmann - 2012-11-18

    Not sure, this is additional help, but here is another steps to reproduce from a duplicate bug report (https://sourceforge.net/p/texstudio/bugs/638/):

    This bug happens when you do the following operations:

    1) Open the internal pdf viewer to view the pdf generated from the tex file.
    2) Right now, the layout should be: left window is tex file, right window is the pdf file
    3) Then, Close the pdf viewer
    4) Now you switch to other program, or switch from current desktop to other. Which means, any operation that would cause the change of menu bar.
    5) You switch back to texstudio, now the menu bar contains only 'texstudio', others like 'File', 'Edit' are all gone.

    Verison: TeXstudio 2.5 (SVN 3394) Using Qt Version 4.8.3, compiled with Qt 4.8.3 R
    OS verison: Mac OS X Mountain Lion 10.8.2

     
  • spieb

    spieb - 2012-11-24

    I just noticed another issue that seems to be related to this bug.
    1. If I start TeXstudio I just see the editor
    2. Then I open the PDF viewer by clicking on the icon, which opens in a separate window
    3. Next I click on the icon to integrate the viewer into the main window
    4. Now the about dialogue of the TeXstudio menu disappears.

    TeXstudio 2.5.1 SVN3414 Qt 4.8.2 OSX 10.8.2

     
    Last edit: spieb 2012-11-24
  • Tim Hoffmann

    Tim Hoffmann - 2012-11-26

    rev. 3509 contains a fix for the vanishing menubar after closing the pdf viewer. Are there any other situations in which you have observed (or still observe) the vanishing menu bar?

     
    • Denis Bitouzé

      Denis Bitouzé - 2013-05-29

      Unfortunately, I still noticed this bug this afternoon, with TXS version:

      http://sourceforge.net/projects/texstudio/files/texstudio/TeXstudio%20SVN/texstudio_svn3941_mac.dmg/download

      which Jan compiled on 25-04-2013 and that is supposed to integrate the bug fix (3941 > 3509).

      I wasn't aware of the steps that make the menu entries disappear so I'm not sure in which conditions it arose today, but I'm pretty it was related to the ones described in this thread.

      I can't test as I don't own a Mac but maybe I could ask one student to be in touch with the TXS team.

       
      • Denis Bitouzé

        Denis Bitouzé - 2013-05-29

        I still noticed this bug

        I mean only the one concerning the menus disappearing.

         
  • Robert

    Robert - 2012-11-26

    Hi Tim. I sent this to Benito. I tried this in SVN3514.

    Ok. If a user is working with one file and activates the embedded window and then opens a new file. If the user next closes the file associated with the embedded viewer, then the menu bar disappears. If I open the embedded viewer though, the menu bar reappears. It seems that this possibility just needs to be patched.

     
  • spieb

    spieb - 2012-11-27

    Cool, it works now, many thanks, this made texstudio a lot more useable on OSX!

     
  • Robert

    Robert - 2012-11-27

    Yes. It works perfectly now.

     
  • Tim Hoffmann

    Tim Hoffmann - 2012-12-03
    • status: open --> closed
    • priority: 5 --> 1
     
  • Jan  Sundermeyer

    Jan Sundermeyer - 2013-05-30

    I would need at least some information when the menu bar disappears
    (fullscreen mode , using virtual screens ,etc).
    Though I don't use txs extensively on mac, i have not seen the
    disappearance yet ...

    On 29.05.2013 20:52, "Denis Bitouzé" wrote:

    Unfortunately, I still noticed this bug this afternoon, with TXS version:

    http://sourceforge.net/projects/texstudio/files/texstudio/TeXstudio%20SVN/texstudio_svn3941_mac.dmg/download

    which Jan compiled on 25-04-2013 and that is supposed to integrate the
    bug fix (3941 > 3509).

    I wasn't aware of the steps that make the menu entries disappear so I'm
    not sure in which conditions it arose today, but I'm pretty it was
    related to the ones described in this thread.

    I can't test as I don't own a Mac but maybe I could ask one student to
    be in touch with the TXS team.


    [bugs:#594] http://sourceforge.net/p/texstudio/bugs/594/ OSX
    Appearance: 1. Font size, 2. Menu disappears

    Status: closed
    Created: Sun Aug 19, 2012 02:24 PM UTC by spieb
    Last Updated: Mon Dec 03, 2012 03:12 PM UTC
    Owner: nobody

    In OSX i set the font size in the appearance options to 9pt (where it
    says "ready" and "normal" mode ). However if i change the virtual
    desktop and then return, the font size is ignored and set to the
    standard value. I guess the window is redraw whenever i change the desktop.
    Sometimes also the menu bar dissappears, but i haven't found a way to
    reproduce this, so i'll keep track of that.


    Sent from sourceforge.net because you indicated interest in
    https://sourceforge.net/p/texstudio/bugs/594/

    To unsubscribe from further messages, please visit
    https://sourceforge.net/auth/subscriptions/

     

    Related

    Bugs: #594

<< < 1 2 3 > >> (Page 2 of 3)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks