#1625 Unicode characters too small with retina display

None
fixed
nobody
None
1
2016-01-15
2013-12-14
Anonymous
No

Most of the unicode characters such as greek symbols and math icons are too small with macbook 15" retina. Any idea?

Related

Bugs: #1521

Discussion

  • CLightfield

    CLightfield - 2013-12-20

    Is this what you have in mind. In the attached screenshot: left=TXS 2.5.2; Right= TXS 2.6.6e.

    rMBP 13" OSX 10.8.5

     
  • Tim Hoffmann

    Tim Hoffmann - 2015-06-29
    • status: open --> closed
    • Group: -->
     
    • Shengchao Hou

      Shengchao Hou - 2015-09-22

      Hi I just downloaded the newest version (2.10.2) and I have the same problem. Only a few symbols are in normal size and the others are still too small to be recognized. Is there a way to solve this problem?

       
      • Benito van der Zander

        Have you tried the GUI scaling options?

         
        • Shengchao Hou

          Shengchao Hou - 2015-09-22

          Thanks for the reply! I tried to increase the symbol size in textstudio.ini, but it turns out that only the frames become larger while the unicode characters in it still remain the same size. And the weird thing is that there are a few characters in normal size while the majority of them are really small..

           
  • Tim Hoffmann

    Tim Hoffmann - 2015-10-01

    When you scale the GUI, the grid size increases.

    • Do the regular-sized icons scale with the grid?
    • Do the too-small icons scale with the grid?
     
    • Shengchao Hou

      Shengchao Hou - 2015-10-01

      Yes the regular sized icons scale with the grid whereas the small icons do not change.

       
  • Tim Hoffmann

    Tim Hoffmann - 2015-10-01
    • status: closed --> open
     
  • CLightfield

    CLightfield - 2015-10-01

    As shown above, I was able to reproduce this issue for some old versions. The problems were resolved for me with version 2.8.8 and I haven't had a need to upgrade since. I don't have time to compile new versions right now, but as a temporary workaround, you might try installing an older version and see if one works. My current system is rMBP 15" and TXS 2.8.8 compiled with Qt 5.3.2.

     
  • Max Schambach

    Max Schambach - 2015-10-22

    I can confirm the behaviour described by Shengchao Hou on OS X 10.11.1 and TXS 2.10.2. As suggested I downgraded to TXS 2.8.8. and everything scales as it is supposed to.

     
  • Tim Hoffmann

    Tim Hoffmann - 2016-01-12

    Ticket moved from /p/texstudio/feature-requests/616/

     
  • Jan  Sundermeyer

    Jan Sundermeyer - 2016-01-15

    work-around implemented

     
  • Jan  Sundermeyer

    Jan Sundermeyer - 2016-01-15
    • status: open --> fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks