Help save net neutrality! Learn more.
Close

#341 Viewing output in DVI not working with inputted tex files

v1.0_(example)
closed-works-for-me
5
2013-06-30
2012-11-30
No

Viewing the output at correct position in DVI viewer Yap seems not to work when the cursor is in a tex file which is inputted to a main file with Latex command \input{}. When the cursor is in the main file, the viewer jumps correctly to the cursor position. If the main file has \input{} command and the cursor is in the file specified, jumping to the correct position does not work.

Discussion

  • Tuomas Välikylä

    Note:

    The output profile LaTeX -> DVI in version 1 RC1 has the following in the viewer's "Forward search": -1 -s "%l%bc.tex" "%bm.dvi"

    The corresponding field of the version 2 Beta 1 has: -1 -s %l"%Wc" "%bm.dvi"

    After I replaced the command by the old version command, the forward search seems to work correctly also with inputted tex files.

     
  • Tino Weinkauf

    Tino Weinkauf - 2012-12-05
    • labels: 434620 -->
    • milestone: 3986995 -->
     
  • Tino Weinkauf

    Tino Weinkauf - 2012-12-05

    The described error has been added to the official bug list.

    Thank you for your report.

     
  • Tino Weinkauf

    Tino Weinkauf - 2012-12-05
    • labels: --> Process Calling (Profiles)
    • assigned_to: nobody --> niteria
     
  • Tino Weinkauf

    Tino Weinkauf - 2012-12-05

    This is a weird error, though. YAP reports a DDE connection issue.

    And YAP jumps to the correct position, if you close it before. In other words, if TXC opens Yap for the first time, then everything is fine. Second and subsequent calls do not work.

     
  • Tino Weinkauf

    Tino Weinkauf - 2013-06-30
    • status: open --> closed-works-for-me
    • Group: --> v1.0_(example)
     
  • Tino Weinkauf

    Tino Weinkauf - 2013-06-30

    Works with the newest version.

     


Anonymous

Cancel  Add attachments