Texlipse and biber

Help
Thomas
2011-07-20
2014-04-28
1 2 > >> (Page 1 of 2)
  • Thomas

    Thomas - 2011-07-20

    Hello,

    for one of my LaTeX-projects it is necessary to use the package biblatex and biber instead of bibtex. Unfortunately I was not able to get Texlipse to run biber. That is I have to run a makefile manually whenever I change the project. I would really appreciate if I could translate my project the usual way, i.e. the build in maker of texlipse, but make it use biber instead of bibtex. Does anyone know a way to do this?
    (I use texlive as tex-distribution if that helps.)

    Thanks,
      Thomas

     
  • Matthias Erll

    Matthias Erll - 2011-07-20

    Hi Thomas,

    I had the same problem when I started a thesis project five months ago. Since I had some extra time in the beginning, I created a patch (3192230) and fixed issues while I was working with it. If you want to, you can download the Texlipse source and apply this patch:
    http://sourceforge.net/tracker/?func=detail&aid=3192230&group_id=133306&atid=726820

    Currently, the only change I would like to add is that it becomes possible to override the automatically detected settings, in case someone moves the package loading to a style file which is not read by the parser. Otherwise I hope this makes it into a release some time soon.

    Kind regards,
    Matthias

     
  • Thomas

    Thomas - 2011-07-21

    Hi Matthias,

    thanks for sharing this information. I don't know if I want to compile Texlipse myself as I do not have much time at the moment. Anyway, I really appreciate you sharing the patch here!
    Is there a chance that this patch will be worked in a future Texlipse update?

    Cheers
      Thomas

     
  • Matthias Erll

    Matthias Erll - 2011-07-29

    Hi Thomas,

    yes, chances seem quite good that this patch or at least the feature makes it into a future release. The next release date is not set yet, but the development is still being continued.

    Cheers,
    Matthias

     
  • drozzy

    drozzy - 2011-10-23

    Hi, Matthias,
    How are you?

    Any updates on biblatex support in Texlipse? Would be cool if you could explain how to enable it. Thanks!

     
  • Matthias Erll

    Matthias Erll - 2011-10-27

    Hi,

    Biblatex support has not been included in the most recent release of TeXlipse, as the implementation had only been tested in my projects at that time, and it caused unwanted side-effects in other environments. However, in the meantime more tests have been performed, and errors have been fixed continuously.

    This patch and others have been modified further and checked into a branch "me" in the Git repository. If you are interested, you can check it out - I would certainly appreciate your feedback.

    If you do not know how to build TeXlipse from the source code, the next release including Biblatex support will probably be available within a few weeks.

    Cheers,
    Matthias

     
  • drozzy

    drozzy - 2011-10-27

    No idea how to build it :-( but will certainly give feedback once its in the release!

     
  • Matthias Erll

    Matthias Erll - 2011-11-30

    Hi,

    TeXlipse version 1.5.0 has been released a few of days ago. It includes the enhancements for biblatex / biber.

    Kind regards,
    Matthias

     
  • Thomas

    Thomas - 2011-12-01

    Hello Matthias,

    thanks! I already saw yesterday, that biblatex/biber is now supported by texlipse and I was really excited to try it.
    Unfortunately it doesn't seem to work. I keep getting the warnings "Empty bibliography" and "Please re(run) Biber on the file…" and no bibliography is shown for my document.
    That is already a success compared to the previous version as back then texlipse wasn't able to recognize that I want to use biber instead of biblatex. Now it recognizes that I want to use biber. The biber.exe was also recognized correctly in the texlipse builder settings. In the log file, the settings of biblatex seem to work, i.e. the configuration file, the citation style and the language are loaded. But then I get the messages that all of my citations are undefined and hence my bibliography is empty. However, if I build the same project with my make file which also uses biber, everything works fine.

    Is there anything that I need to set up in texlipse/eclipse in order to get biber working or do you have any idea what could be wrong here?

    I'd appreciate any help
      Thomas

     
  • AlexR

    AlexR - 2011-12-05

    Hi there,

    got the same problem like Thomas.

    During build there is no bbl file created. Like Thomas said biblatex seems to work properly.
    But in the logfile/console there is no line stating "biber" (exept from the "Please (re)run Biber on the file…" line).
    I think there should be a line saying "This is Biber Version xxx" or something like that.

    So it seems that biber.exe is not invoked at all.

    Please help us! ;)

    Greez
       Alex

    PS: Nice work nonetheless!

     
  • Matthias Erll

    Matthias Erll - 2011-12-06

    Hi Thomas,
    Hi Alex,

    sorry you are still having trouble with biblatex support. Could you both please post a short sample / excerpt, possibly just from your preamble? That would make it easier to analyze and possibly debug.

    Cheers,
    Matthias

     
  • AlexR

    AlexR - 2011-12-06

    Hi,

    here is my preamble from one of the docs i tried compiling:

    \documentclass[article,noresetcounter,accentcolor=tud1c, notitlepage]{tudreport}
    \usepackage[T1]{fontenc}
    \usepackage[utf8]{inputenc}
    \usepackage[ngerman]{babel}
    \setlength{\parindent}{0pt}
    \setlength{\parskip}{6pt}
    \graphicspath{{./graphics/}}
    \renewcommand\thesection{\arabic{section}.}
    \renewcommand\thesubsection{\thesection\arabic{subsection}.}
    \renewcommand{\thefigure}{\arabic{figure}}
    \usepackage[style=numeric-comp,backend=biber]{biblatex}
    \usepackage[babel,german=guillemets]{csquotes}
    \addbibresource{literaturverzeichnis.bib}
    

    (the document class "tudreport" is based on "scrreport", it implements the corporate design of my university)

    If you need anything else don't mind to ask ;)

    Greez
    Alex

     
  • Matthias Erll

    Matthias Erll - 2011-12-07

    Hi Alex,

    I copied your preamble, and after creating a sample bib file it worked right away. I guess the parser finds the \usepackage command for biblatex and should therefore generally know what to run. Could you please send me your log files (possibly to my private email "merll at web dot de")?

    Additionally, could you check whether anything changes when you temporarily change the "backend=biber" option into "backend=bibtex"?

    Cheers,
    Matthias

     
  • AlexR

    AlexR - 2011-12-07

    Sent you an email…

    Did as you said and attached all temp-files for each build. Nothing changed on using bibtex, except from the complaint about utf-8…

    Greez
    Alex

     
  • Anonymous - 2011-12-12

    I'm also seeing this problem on Eclipse 3.7.1 (running on Linux). The file compiles ok, so it can't be a faulty TeX installation.

     
  • Anonymous - 2011-12-16

    Hi,

    i have the same Problem too, i have to run biber manually to not have an empty bibliography. I'm using Eclipse SDK Version: 3.7.1.

    Cheers,
    Flo

     
  • Matthias Erll

    Matthias Erll - 2011-12-16

    Hi,

    thanks to Alex and Thomas for providing samples, which helped me to track these issues. There are some limitations in the biblatex support, which I should point out:

    - The backend option is not read correctly by the parser, if it is in the first position (right after the square bracket) of the usepackage command. This is a bug and will be fixed in a future release. It can be circumvented, either by changing the order of the biblatex package options, or by putting some whitespace in front of the backend option.

    - TeXlipse can currently only detect that you are using biblatex, if the parser can find a line of \usepackage{biblatex} in the main file of your project. It is currently not possible to change this without major modifications in the builder framework. However, a new approach towards detection of biblatex and other required utility programs, which will not be subject to this limitation, is currently under development. If you need to work around this issue (e.g. because biblatex is part of your class or package file), you could place something like this in the preamble of your main document:

    %###
    \newcommand{\onlyacomment}[1]{}
    \onlyacomment{%
    %###
    \usepackage[%
    backend=biber
    ]{biblatex}
    %###
    }
    %###
    

    This way the parser does not notice, that you are using a macro definition without any effect on your document. Not very elegant, I know, but I am currently working on ways to fix this.

    - Partial builds work; however, if partially built files have their own preamble, you should temporarily set them as a main files. I could not reproduce these problems reliably, but sometimes the use of biblatex was not detected correctly, if another file than the main tex-document was built with its own preamble.

    - The builder sequences (e.g. latex+dvips+ps2pdf) have not been prepared for the changes, which were necessary for biblatex. Single builders such as pdflatex, luatex, and xetex are supported. Currently I am not entirely sure how this can be extended to the sequential builders, but I hope to have some solution for the next release.

    - If biblatex is detected, \bibliography does not tolerate more than one file entry as a parameter. This is allowed by biblatex, but would require more differentiation in the TeXlipse parser. The biblatex manual generally discourages the use of this command, as it is deprecated; therefore, you might want to use several lines of \addbibresource instead.

    As said above, I will try to fix most of these issues before the next release is out. I hope until then my descriptions help to work around them.

    @colorblind and @Flo: If none of the described limitations apply to your project, please send me a sample tex-file for reproducing the problem. I will try to analyze this further as soon as possible.

    Kind regards,
    Matthias

     
  • Anonymous - 2011-12-18

    Hi Matthias,
    i changed the order of the options and now everything works fine. Thank you for helping, and thank you a lot for your great work on this project!

    Cheers,
    Flo

     
  • Anonymous - 2011-12-19

    Hi Matthias,

    Thanks for the effort! I found the problem in my case: the parser didn't interpret the line

    \addbibresource{bibliography}

    correctly. When I changed it to

    \addbibresource{bibliography.bib}

    everything worked.

     
  • Jaroslav Fait

    Jaroslav Fait - 2011-12-30

    Hello, I have the same problem as Thomas. I am using xelatex, and in the statement, in the console window, see:
       xelatex.exe> Package biblatex Warning: Please (re)run Biber on the file:

    using: Texlipse 1.5.0
    main file:
    \documentclass{book}
    \listfiles
    \usepackage{fontspec,xltxtra,xunicode}
    \usepackage[backend=biber, backref=true,      %
               hyperref=true,      %
               refsection=section, %
               firstinits=true,    %
               style=alphabetic,   %
               indexing=true,      %sortcites=true
               url=false,doi=false]{biblatex}
    \addbibresource{../src/lib/Library.bib}
    \usepackage{xcolor} 
    \usepackage{titlesec} 
    \usepackage{fancyhdr}  % Customising with fancyhdr
    \usepackage[xetex,
                bookmarks={true},        %  A set of Acrobat bookmarks are written
                colorlinks={true},       %  Colors the text of links and anchors. The colors chosen depend on the the type of link.
                linkcolor={red},         %  Color for normal internal links.
                anchorcolor={black},     %  Color for anchor text.
                filecolor={cyan},        %  Color for URLs which open local files.
                menucolor={red},         %  Color for Acrobat menu items.
                runcolor={blue},         %  Color for run links (launch annotations).
                urlcolor={magenta},      %  Color for linked URLs.         
                unicode={true}, 
                pdfauthor={Jaroslav Fait},
                pdftitle={Wiking},
                pdfsubject={study notes},
                pdfkeywords={linear algebra, math},
                pdfproducer={XeLateX with hyperref},
                pdfcreator={Xelatex}]{hyperref} 

    \usepackage{minitoc}
    \usepackage{../src/lib/wiking}
    \usepackage{parskip}
    \usepackage{setspace}
    \usepackage{listings}
    \usepackage{amssymb}
    \usepackage{amsmath} 
    \usepackage{graphicx}
    \usepackage{xy}          % X-pic: The picture environment and gnuplot
    \usepackage{wrapfig}          % Floats, Figures and Captions 
    \usepackage{subfigure}        % Multipart figures
    \usepackage{caption}
    \usepackage{sidecap}          % Side captions
    \usepackage{tikz}
    \usetikzlibrary{matrix,arrows,decorations.pathmorphing}
    \usepackage{verbatim}
    \usepackage{booktabs}
    \usepackage{multirow}         % Columns spanning multiple rows
    \usepackage{indentfirst}      % indent the first paragraph
    \usepackage{array}            % Using the array package, the column specification can be altered
    \newcolumntype{C}{>{\centering}m{#1}} % buňka bude centrovaná horizontálně i vertikálně - nutný balík array !
    \usepackage{animate}
    \usepackage{listings}
    \usepackage{pdfpages} 

    In the directory tmp, I see only an empty file main.bbl. I'm very frustrated and don't know where is the error.

    Kind regards,
    Jaroslav
          
             

     
  • Matthias Erll

    Matthias Erll - 2011-12-31

    Hi Jaroslav,

    due to a bug in the current implementation, the backend option does not work correctly, if it is placed right after the first square bracket. Please try changing the line of

    \usepackage[backend=biber, backref=true, %[/code]
    into
    [code]\usepackage[backref=true, backend=biber, %[/code]
    and see if it works. Otherwise, please check if any of the other limitations that I pointed out in this thread above applies to your project. These problems will likely be resolved in a future version.
    Kind regards,
    Matthias
    
     
  • Christoph

    Christoph - 2012-11-07

    Although this thread is quite old I have the same problem with a file using biber.

    Instead of calling biber, bibtex is called:

    running: C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\bibtex.exe thesis 
    bibtex.exe> This is BibTeX, Version 0.99d (MiKTeX 2.9)
    

    - I am using pdflatex
    - I got the latest code from git today (7/11/12)
    - I can workaround the problem by specifying biber as the executable for bibtex.

    Package declaration:

    \usepackage[%
    backend = biber,
    bibencoding = utf8,
    defernumbers=true,
    natbib = true,
    style = numeric-verb,
    maxnames = 12,
    minnames = 1,
    backref = true,
    backrefstyle = two,
    ]{biblatex}
    

    Any help is appreciated.

    Thanks!
    Christoph

     
  • Matthias Erll

    Matthias Erll - 2012-11-08

    Hi Christoph,

    I guess the parser for this is still a bit sensitive. Could you please change

    backend = biber,
    

    into

    backend=biber,
    

    and see if it works then? I will try to fix that as soon as possible.

    Kind Regards,
    Matthias

     
  • Christoph

    Christoph - 2012-11-09

    That  did the trick. Thanks Matthias.

     
  • Robert S.

    Robert S. - 2013-09-24

    Hi,
    I was searching for days because Texlipse (1.5.0) was not invoking biber.exe at all! I knew it because there was only: Empty bibliography on line x, and Please (re)run Biber.exe! errors
    Also there was no pca-xxxx cache folder created in appdata/local/temp folder (on windows) (which always gets created on first call of biber.exe)
    i am currently using this line:
    \usepackage[authordate,backend=biber,bibencoding=auto,strict]{biblatex-chicago}

    • removing or inserting " " was no solution
    • writing a own custom build script was also no solution for me (because it suddenly stopped working! wt*)

    so what i did was changing in the build settings (window/preferences/texlipse/builder settings) for bibtex to path/to/miktex/bin/directory/biber.exe.
    so there is now bibtex program and biber (biblatex) linked with biber exe! I dont know why, but it started working for me

    This was really frustrating for me and a lot of time was killed by that!
    Hope that will help someone out there to fix it in a few seconds ;)

    bb

     
    Last edit: Robert S. 2013-09-24
1 2 > >> (Page 1 of 2)

Log in to post a comment.