Tess4J on Tomcat

Help
Anonymous
2012-02-25
2014-08-28
  • Anonymous - 2012-02-25

    Hi,
    I have some trouble on tess on a web application.

    Mi OS is WinXp and the application server is tomcat 6.

    In stand alone mode is all ok, but whene i try to perform a text recognition on tomcat i have this exception:
    java.util.NoSuchElementException
    at javax.imageio.spi.FilterIterator.next(ServiceRegistry.java:808)
    at javax.imageio.ImageIO$ImageWriterIterator.next(ImageIO.java:816)
    at javax.imageio.ImageIO$ImageWriterIterator.next(ImageIO.java:801)

    What can be the problem?
    I tried with jai_core.jar, jai_codec.jar, jai_imageio.jar both on {tomcat_home}/lib and WEB-INF/lib but i always go on exception.

    Help me!
    Thanks.

     
  • Anonymous - 2012-02-27

    Thanks for the reply.

    I'm at very new on imageIO so I don't understand.
    What was wrong in that case?

    I think the final answer was this one:
    Finally it is working. I was not trasnferring(jars, tiff images etc) the files to solaries box in binary mode. So all the files were corrupted and JRE was not able to pickup the plugins.

    Thanks,
    Prashanth

    But, sorry I don't unterstand!
    Can you "translate" for me.

    Thanks again.

     
  • Quan Nguyen

    Quan Nguyen - 2012-02-28

    That user seemed to have FTPed the files in text mode, hence corrupting the binary files.

    I'm not experienced with Tess4J on a web environment, but make sure the .jar files are in in the classpath.

     
  • Dmitry Katsubo

    Dmitry Katsubo - 2014-08-28

    In case someone gets interested I have accumulated some posts related to the problem and solutions here.

     
    Last edit: Dmitry Katsubo 2014-08-28

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks