#173 add first and last page recommandation for biblScope

GREEN
closed
nobody
5
2009-03-30
2009-02-26
Anonymous
No

I suggest to add fpage and lpage as recommended values for biblScope/@type in the documentation. Reason is:
- we often need to encode more precise information in bibliographical references
- meta-data provided by publishers differentiate between first and last page information in their format and one may want to keep this precision
- there is quite some heterogeneity in the way pp content is encoded (e.g. with or without white spaces, double dash, etc.)
- documenting these fpage and lpage recommendation would help such data be interoperable (quite a few projects are already using similar value, but with quite a variety of labels)

Discussion

  • Laurent Romary

    Laurent Romary - 2009-02-26

    Forgot to log in. I submitted it. Laurent

     
  • Lou Burnard

    Lou Burnard - 2009-03-14
    • milestone: --> 871207
     
  • Lou Burnard

    Lou Burnard - 2009-03-14

    how about @fromPage and @toPage (and no content): like
    <biblScope fromPage="1" toPage="23"/>
    as an alternative to
    <biblScope type="pp">1-23</biblScope>
    or (I suppose)
    <biblScope fromPage="1" toPage="23">pp 1-23</biblScope>
    This leaves open the question of what to do in the case of inconsistency:
    <biblScope fromPage="1" toPage="23">pp 1-233</biblScope>

     
  • Lou Burnard

    Lou Burnard - 2009-03-14
    • milestone: 871207 --> 871209
     
  • James Cummings

    James Cummings - 2009-03-15

    I'd agree with Lou except on the names of the attributes. I wouldn't want 'Page' to be included in the attribute. (i.e. biblScope could be documenting a range of line numbers or other things.) However, @from/@to is used for both data.pointer and data.temporal in various elements. I'd also hate to extend @from/@to just to be data.numeric or something on this element. @biblFrom @biblTo just seem to reiterate information we know from the element name.

    So I'm in favour, but just with better names. ;-)

     
  • Peter Boot

    Peter Boot - 2009-03-16

    @from/@to has type data.word on locus. That would seem appropriate here too.

    Like James, I wouldn't like @fromPage and @toPage, because pages would then be handled differently from volumes, chapters, etc.

     
  • Arianna Ciula

    Arianna Ciula - 2009-03-18

    I also agree with James here.

     
  • Lou Burnard

    Lou Burnard - 2009-03-22

    The proposal original submitted was specifically about page ranges, since these are very commonly encountered in bibliographies. If you generalise it to ranges of any kind, you will need to require that the @type attribute be supplied (or has an explicit default) Otherwise you can't tell what <biblScope from="1" to="3"/> actually means.

     
  • Lou Burnard

    Lou Burnard - 2009-03-22
    • milestone: 871209 --> GREEN
     
  • Lou Burnard

    Lou Burnard - 2009-03-30

    Implemented @from and @to, with requirement that @type be used to indicate what, at revision 5926

     
  • Lou Burnard

    Lou Burnard - 2009-03-30
    • status: open --> closed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks