#453 <castGroup> should be named <castGrp>

RED
closed-wont-fix
5
2013-02-01
2012-10-09
No

As pointed out by Torsten Schassen on another ticket on a different topic, now closed (http://purl.org/TEI/FR/3561938), all grouping elements use the nomenclature *Grp, with the exception of <castGroup>. Should <castGroup> be renamed to <castGrp> for consistency?

Discussion

  • Lou Burnard

    Lou Burnard - 2012-11-04

    Except that for all other *Grp elements there exists an element called * which is the child of the *Grp. Strickly speaking, it should be castItemGrp. Yuk.

     
  • James Cummings

    James Cummings - 2012-12-26

    If we get into this icky quagmire, castList shouldn't that be listCast? Maybe not....
    Assigning to martindholmes to keep tabs on.

    castItemGroup.... Frankly I've never understood why we need a separate form of list for castlists.... why is it not just list/@type='cast'?

    As a result... I'm reluctant to change things and make them worse. ;-) So I'd vote for the status quo in this case... pending any large revisting of performance text markup. But I accept that my reasons aren't very good.

    -James

     
  • James Cummings

    James Cummings - 2012-12-26
    • milestone: --> RED
    • assigned_to: nobody --> martindholmes
     
  • Martin Holmes

    Martin Holmes - 2013-01-07

    My vote is to ignore this for now, because it's too disruptive to change, and the inconsistency is cosmetic rather than structural. We should make a decision at the next ftf meeting.

     
  • Lou Burnard

    Lou Burnard - 2013-01-09

    I agree we shouldnt change this. The definition makes clear that <castGroup> is intended for groups of castItems within a castList -- so it's not quite the same as a castList (because it cannot stand alone). If we want to pursue the analogy with other *Grp elements we would have to rename it "castItemGrp" which just looks silly.

     
  • Martin Holmes

    Martin Holmes - 2013-02-01

    There seems to be no enthusiasm for making this change, so I'm closing this ticket.

     
  • Martin Holmes

    Martin Holmes - 2013-02-01
    • status: open --> closed-wont-fix