Regina Shen - 2010-10-11

I am a tcl beginner. Please help

step 1: download dict 8.5.1, hunddle.tcl and yaml.tcl from TEA
step 2: make PkgIndex
step 3: test
here is my test script:

#! /usr/bin/tclsh

lappend auto_path /home/rshen/bin/lib

package require yaml 0.3.5

::yaml::yaml2dict -file template.yml

And always got an error "invalid command name "::yaml::yaml2dict""

what should I correct?

Thanks!!!