Hi,

Sorry for the late reply, but I get a lot of spam on this mail address, and so I missed these messages originally...

Thanks for fixing the problem. I just tried tcl 8.5.7, and saw the change to the dlopen call, and running tclsh, it is now able to load the two files.

I don't know if this is a related problem, but I tried to work around this problem by compiling tcl/tk 8.5.6 with weak linking, with MACOSX_DEPLOYMENT_TARGET set to 10.3. I was able to load the two files into tclsh by doing this, but there is still a problem in the actual Tcl.Tk program, which I am unable to run, because it requires Tk, and I can't run Tk because I have only remote access to the Mac OS X machines I am using.

I asked a friend to run the original program on his Mac, and he reports that he gets
a `lazy symbol binding failed' error, for the same symbol that is defined in one file and used in the other file that are loaded:

pmmbp:~ pmoura$ tkeclipse
/Users/pmoura/Documents/Prolog/eclipse/tcltk/i386_macosx/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/Scripts
dyld: lazy symbol binding failed: Symbol not found: _EcTcl2Exdr
  Referenced from: /Users/pmoura/Documents/Prolog/eclipse/lib/i386_macosx/tkeclipse.dylib
  Expected in: flat namespace

dyld: Symbol not found: _EcTcl2Exdr
  Referenced from: /Users/pmoura/Documents/Prolog/eclipse/lib/i386_macosx/tkeclipse.dylib
  Expected in: flat namespace

/Users/pmoura/Documents/Prolog/eclipse/tcltk/i386_macosx/bin/wish8.5: line 2: 30002 Trace/BPT trap          "$(dirname $0)/../Library/Frameworks/Tk.framework/Versions/8.5/Resources/Wish.app/Contents/MacOS/Wish" "$@"

Since I am unable to run Tk, I have not been able to track this problem down, but I suspect the error only occurs when the missing symbol is used (it is a procedure name) from tkeclipse.dylib.

I had expected that with weak-linking and dlopen being unavailable before OS X 10.4, Mac Tcl 8.5 would revert to using the old code that was used in Tcl 8.4, which I know was working. However, this error would suggest that the alternative to calling dlopen() in Tcl 8.5 also do not make the symbols loaded with a dylib file global.

Is this also a known problem?

Thanks and cheers,

Kisht