I tried this out at the weekend for the first time.  Vincent's right that the patch applies cleanly to Tk 8.4.9 and not to later versions, but I don't think it would be all that difficult to make the changes by hand: only one or two hunks failed.

For myself, I was absolutely amazed at the improvement in the quality of the text display with the patch applied.  I remember that some concern was expressed about the speed of the display (though in my applications this was not a problem at all) which is why the patch has not been applied to the CVS.  If it isn't too difficult to re-work the patch to this end, perhaps the best solution would be to allow ATSU to be turned on or off from the script, rather like we do for anti-aliased text or QuickDraw graphics.

In the meantime, those not using it are definitely missing out on a wonderful piece of work.


vincent rioux wrote:
well, please disregard my last email, i just tried to compile 8.4.9 considering the release date of the atsu8.4 patch, and it is actually working nicely!
many thanks for the tips,

vincent rioux wrote:
Hi Alastair,
Just tried to compile tcltk with Benjamin's patch for unicode fonts display.
Tried it with 8.4.12 and then 8.4.10 with no success.
With the patch on tk8.4.10, i get numerous errors of non declared symbols.
Worse, without the patch i still can't compile tcltk8.4.10, at the very last compillation step, i get this:
ld: warning prebinding disabled because of undefined symbols
ld: Undefined symbols:
I guess i must be wrong somewhere.
Is there a version of tcltk that is known to compile on 10.3 with this patch?
best regards,

Alastair Davies wrote:

My understanding is that at present TkAqua cannot draw all Unicode
characters, but that Benjamin Riefenstahl has developed a patch (see message
below) to enable it to do so.  

I hope this helps,
Kind regards, Alastair

-----Original Message-----
From: Benjamin Riefenstahl
Sent: 18 March 2005 14:09
Subject: Re: [MACTCL] Unicode in Aqua Tk

Hi Linus,

"Linus Nyberg" writes:
I read something about ATSU not being easily pluggable into the Tk
structure, but I just want to know what the current status is...

Unicode doesn't work satifactorily with the QuickDraw API used in the
current Tk source.

I wrote a patch for using ATSU instead, see
This implementation is slower than the QuickDraw based stuff in some
situations, so I am working on optimizations, before this can go into
CVS.  Unfortunately, optimizing and testing is going slow and I can
only devote limited time to it.


-----Original Message-----
From: vincent rioux
Sent: 19 October 2005 12:24

thank you for your reply.
well, i already tried to change of font, but still it won't take this index.

from Tkinter import *
import tkFont
root = Tk()
myFont = tkFont.Font(size=24, family='Junicode')
w = Label(root, text=u'\u0254', font=myFont)

you can find junicode on the web:

for the code of the character I wanted to display : 

by advance many thanks

Russell E. Owen wrote: 
In article <4354C5DE.5030003@no-log.org>,
 vincent rioux <vincent.rioux@no-log.org> 

w = Label(root, text=u'\u0254')
This should display an 'open o' of the IPA.
It happens to work with python from FINK (hence using x11) but I just 
can't get it to work on pythonw2.4/tcl-tk acqua. It will only display an 
empty square....

My guess is that the font you are using is missing the character in 
question. Try setting the font of the widget to something with a richer 
character set.

-- Russell

This SF.Net email is sponsored by:
Power Architecture Resource Center: Free content, downloads, discussions,
and more. http://solutions.newsforge.com/ibmarch.tmpl
Tcl-mac mailing list