#2550 clock format - wrong ISO8601 week number

obsolete: 8.4.5
closed-fixed
5
2004-05-18
2003-12-02
Anonymous
No

For December 31 1999 we get
clock format [clock scan "12/31/1999"] -format "%V"
=> 52
1 day later
1 January 2000 we get
clock format [clock scan "01/01/2000"] -format "%V"
=> 53
And it should be 52

Platform windows XP
No problem on linux.

Discussion

  • Donal K. Fellows

    • labels: 105657 --> 06. Time Measurement
    • assigned_to: dkf --> kennykb
     
  • Kevin B KENNY

    Kevin B KENNY - 2004-03-05
    • status: open --> closed
     
  • Kevin B KENNY

    Kevin B KENNY - 2004-03-05

    Logged In: YES
    user_id=99768

    This is indeed a bug in compat/strftime.c.

    I have code in my sandbox that fixes it. Alas, it needs to
    wait until I can TIP up the rewrite of [clock].

    Which, incidentally, eliminates compat/strftime.c
    altogether.

     
  • Kevin B KENNY

    Kevin B KENNY - 2004-03-05
    • summary: clock format --> clock format - wrong ISO8601 week number
     
  • Kevin B KENNY

    Kevin B KENNY - 2004-03-05
    • status: closed --> closed-duplicate
     
  • Kevin B KENNY

    Kevin B KENNY - 2004-03-05

    Logged In: YES
    user_id=99768

    Duplicate of 500285

     
  • Kevin B KENNY

    Kevin B KENNY - 2004-05-18
    • status: closed-duplicate --> open-remind
     
  • Kevin B KENNY

    Kevin B KENNY - 2004-05-18
    • status: open-remind --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks