This is a long story ...(and I found 3  cases like me, go on and see..)    
First of all , Introduce the victim :
 My desktop PC is Lenovo ThinkCentre M57p , with winbond v1.2 TPM and Intel Q35 chipset,support VT-x , VT-d and TXT.
 I am going to use tboot to launch Xen.
 The OS is Ubuntu 9.04 32bit Desktop Version. Xen is v3.4.2, tboot version is 20090330, SINIT AC module is Q35_SINIT_17.BIN
Then , Belows are what I have done:
 Step 1 : I enabled the TPM , VT,VT-d,TXT in BIOS ; OK!

 Step 2 : In Ubuntu , I make & make install trousers 0.31
 There are some bugs to fix When build in Ubuntu 9.04(which have been solved in new trousers 0.32):(Added #include <limits.h> to remove INT_MAX undeclared error during build.---In Files : trspi/crypto/openssl/symmetric.c,tspi/tspi_aik.c and tspi/tsp_ps.c) OK!

 Step 3 : I make & make install tpm-tools; then execute $tpm_takeownership -z, and set the owner password. OK!

 Step 4 : make & make install tboot(excluded trousers in
 There are a few "warning as error" during make ,It seems gcc in ubuntu 9.04 is not compatible with tboot's makefile options, So I degrade the gcc to 4.1 , Solved! OK!

        Step 5 : I Defined the LCP and Wrote it to TPM NV as docs/policy.txt says, and edited the menu.lst follow the README. OK!

 Until now , all right .

Now the problems coming:
 When I reboot to start the tboot, it stops at

TBOOT: unsupported BIOS data version (1)
TBOOT: TPM: access reg release locality timeout
TBOOT: shutdown_system() called for shutdown_type: TB_SHUTDOWN_HALT 

 So I search it in source code , and find it in tboot/txt/heap.c, then I comment the lines which  check the bios version

/* check version */
//    if ( bios_data->version < 2 ) {
//        printk("unsupported BIOS data version (%u)\n", bios_data->version);
//        return false;
//    }

 After that a likely check failure happened when check num_logical_procs just below bios check(in heap.c),and I also comment that check too.

    /* all TXT-capable CPUs support at least 2 cores */
//    if ( bios_data->num_logical_procs < 2 ) {
//        printk("BIOS data has incorrect num_logical_procs (%u)\n",
//               bios_data->num_logical_procs);
//        return false;
//    }

Here is a same case as me ......= =!!
 Reboot....This time , it hangs in

TBOOT: executing GETSEC[SENTER]...

 (I used the serial and export the output to another PC to see it)

 Then I have to hold the power button to shutdown the computer.

 By the way , I didn't add "iommu=required" in line of tboot.gz and "iommu=1 vtd=1" in line of xen-3.4.2.gz in menu.lst. Is it necessary to trun on VT-d to run tboot correctly?

Here is a similar case like me ......= =!!
 There Hal suggest that roll back the BIOS may make a differerce.

 But I can't find the earlier BIOS version for my ThinkCentre ,So I don't know if degrading the BIOS take effect.Then I wonder it may be the problem of the LCP. So I use the lcptools/tpmnv_relindex to release the policies those I had defined.Then reboot.......then
 "Something went wrong. My laptop(desktop) hung and I restarted it. But it didn't start properly. The power light and other lights came on, but the display did not light up. The fan started and disk began spinning, but after about a second, the whole thing powered down. The fan and disk stopped, and all of the lights went out. Then, after a few seconds, it turned itself back on. But once again, after starting the fan and disk, and before lighting the display, the laptop shut off. This cycle would repeat indefinitely, the laptop turning itself on and off. I have to make it stop by pressing and holding the power button."

 "In short, my laptop(desktop) was completely broken and useless."

 "Fortunately, being new it was covered by HP's(lenovo's) warranty."
 "They had replaced the motherboard and it worked fine. So I tried again. I enabled the new TPM, got VT and TXT enabled, and tried launching tboot."

 "It broke again."

 "Once again my laptop(desktop) is useless. It repeatedly turns itself on and
off, and does not even light up the display. It does not get far enough into BIOS to boot from a CD or any other medium."

------from Hal Finney <<tboot broke my laptop! (twice!)>>

......= =!!

 God,Exactly the same to me !!!!

 I'm  about what caused it to broke, BIOS or tboot??
 Is there anybody who run tboot successful in ThinkCentre M57p , Please help me.