I ran into the same issue on the GM45 (Montevina) platform with the integrated iTPM. It is a known problem with the either the Linux tpm_tis driver and/or the iTPM itself. I don't think there is a plan to fix it. I did not actually find out what the problem was since the platform I ended up using had a discrete 3rd party TPM and there were no issues. It might be possible to fix/workaround  the the issue in the Linux driver if we determined what the actual problem is. Not sure. Is there any way to add a discrete TPM to this system?
 
Thanks
Ross


From: Weide Zheng [mailto:zhwade@gmail.com]
Sent: Thu 11/27/2008 9:18 AM
To: tboot-devel
Subject: [tboot-devel] Problem about TPM driver on GM45

Hi all,
I am happy to find that the SINIT AC Modules for GM45 have released. I downloaded the code and tried it on two latest machines with GM45 chipset-- Lenovo T400 & X200. But unfortunately, I was surprised to find that TPM devices can not even  be  detected. I have tried the latest linux-2.6.27.7 kernel and used "modprobe tpm_tis" command, but the device still remain undetectable. Have you ever come about similar problems? Does the tpm integrated in GM45 need special driver support?
P.S. : TPM device in these two machines work fine in windows xp& Vista environment.
I will be greatly grateful for your advise.
 
2008-11-27

Weide Zheng