Hi all,

 

I am trying to compile the latest tboot version on Fedora 20. I am facing the following error when running make:

 

trousers-devel package is not installed

 

I read that I have to install the package in advance. Output of rpm –qa

 

# rpm -qa | grep -i trousers

trousers-static-0.3.11.2-3.fc20.x86_64

trousers-devel-0.3.11.2-3.fc20.x86_64

trousers-0.3.11.2-3.fc20.x86_64

trousers-devel-0.3.11.2-3.fc20.i686

trousers-0.3.11.2-3.fc20.i686

trousers-static-0.3.11.2-3.fc20.i686

 

I checked the include path of my gcc with

 

`gcc -print-prog-name=cc1` -v

 

#include <...> search starts here:

/usr/lib/gcc/x86_64-redhat-linux/4.8.2/include

/usr/local/include

/usr/include

 

And the /usr/include directory is listed (tss.h is located at  /usr/include/trousers/tss.h).

 

I also tried out the tboot RPM with version 1.7.x. But with this package I am not able to load/communicate with the TPM. After booting with the 20_linux_tboot grub2 entry I have no /dev/tpm0 device.

 

Any help is greatly appreciated.

 

Thanks in advacne!

Philipp