#463 auto startup problem

Release_0.72.5
closed
Linux (158)
windows
1
2012-12-18
2009-04-08
Brendan
No

On Debian testing if you include Task Coach (using the command taskcoach.py ) as an automatic startup program in your session management upon loading metacity task coach will never successfully load its own panel icon making it in-accessible and requiring the process to be manually killed and restarted. Manually starting Task Coach works fine.

Discussion

  • Frank Niessink

    Frank Niessink - 2009-04-08

    Hi Brendan,

    This works for me on Ubuntu Jaunty (beta). Can you provide more details about what you are doing and what information you are entering where?

    Thanks, Frank

     
  • Brendan

    Brendan - 2009-04-09

    Hi Frank

    To set it up I just went to System / Preferences / Sessions clicked Add. Gave it a name and used "taskcoach.py" as the command. When the system starts Task Coach does generate a panel icon however the icon sites on the far top left side of my screen just under the panel. It continues to work just fine, but not in the panel. If I stop and restart it, it then goes into the panel correctly. Not sure what else I can tell you, I use do use Compiz if that makes a difference, but so does Ubuntu by default I think.

     
  • Frank Niessink

    Frank Niessink - 2009-04-09

    We could reproduce the bug you reported. We'll do our best to fix it as soon as possible.

    Thanks, Task Coach development team

     
  • Frank Niessink

    Frank Niessink - 2009-04-09

    Hi Brendan,

    When I first tested it I logged out and then logged back in: the TC icon was correctly shown in the panel. However, when I started up this morning, TC did start (the main window was shown), but no icon in the panel. That's good, now I don't need to install Debian, but can just debug on Ubuntu :-)

    Cheers, Frank

     
  • Aaron Wolf

    Aaron Wolf - 2012-12-17

    Could you please let us know if this is fixed in the latest versions of things? I expect so, but would like confirmation before closing this old ticket.

    Cheers,
    Aaron

     
  • Aaron Wolf

    Aaron Wolf - 2012-12-17
    • status: open --> waiting
    • platform_s: --> windows
     
  • Brendan

    Brendan - 2012-12-18

    Hi Aaron

    The start issue is resolved in newer versions thanks. There is a minor semi-related issue with the panel icon itself though, it doesn't appear to have a correct gamma / transparent background set and only shows a black background. See attached image.

    Thanks

     
  • Aaron Wolf

    Aaron Wolf - 2012-12-18
    • status: waiting --> closed
    • priority: 3 --> 1
     
  • Aaron Wolf

    Aaron Wolf - 2012-12-18

    Thanks for confirming. Please open a new bug report for the other icon issue.

    Cheers,
    Aaron

     

Log in to post a comment.