GD 1212-R Jumpy Cursor.

  • Aaron

    Aaron - 2009-03-05

    My GD 1212-R exhibits a jumpy cursor.  It jumps in a particular way, though.  It seems that there are bands, both vertical and horizontal that act as "blindspots" that the cursor cannot access.  I have tried various combinations of drivers and and configurations in the TabletMagic Testing Panel scroll down menu.  No luck.

    Any help would be great...I would be glad to provide a log of details if there is a way to capture such information.


    bringFire at gmail dot com

    • Aaron

      Aaron - 2009-03-07


      I spent some time playing with all of the settings in TabletMagic as well as configurations for the aplication.

      Here are some results:

      My setup:

      iMac G5 2.0GHz
      Tiger OS 10.4.11

      Wacom Intuos GD 1212-R v1.2-7 ---with DB9 Serial output cable.

      No-Name Prolific PL2303 USB-Serial adapter.

      OpenSource PL2303 drivers

      TabletMagic 2.0b16

      Basically, I found out that I cannot use any of the Mapping or Testing options...I can't even touch those panels otherwise I have to uninstall the drivers and Tablet Magic---remove the .kext file, Extensions.kextcache, Extensions.mkext, TabletMagic preference list, TabletMagic Preference pane application, and PL2303 Receipts.

      Then install drivers with Wacom Tablet unplugged.  Shutdown.  Plug in Wacom Tablet.  Turn it on.  Start up, iMac.  Install TabletMagic.  Open System Preferences.  Go To TabletMagic Panel.  Find correct port in scroll down menu.  Select Port.  Enable Daemon.  Close System Preferences.

      This will allow for a some what limited use of the Tablet, but at least the movement is smooth and operable.  Combined with a mouse, at least I am able to draw in Flash CS4 and Illustrator---without pressure sensitivity.

      I'm fine with that for now...we'll see how long it is stable....

      Waiting on a Keyspan USA-19HS Adapter...hope that the new drivers and adapter help...

      Will post later.


      • Scott Lahteine

        Scott Lahteine - 2009-03-09


        Sorry for the slow reply - what a week!

        If you continue to have troubles, maybe I can help you via Skype video or iChat video. That would be the most direct way to see what's going on. Have you tried earlier versions of TabletMagic to see if perhaps I introduced a bug in b16?

    • Aaron

      Aaron - 2009-03-10


      Thanks for your reply.  I'm getting the Keyspan USA 19HS adapter this week via I'll try that with the new drivers as well as the older versions (something I never considered..thanks!).

      If those don't work, then I will take you up on your offer for some "live" support.

      I appreciate all of your efforts and will keep you informed as to progress.

      Question.  I'm new to the OpenSource stuff and I'm not exactly sure how to get the source and previous builds.  I have Fink installed, but can't find TabletMagic in the directory...any quick advice?

      Ok, off to search.

      Thanks Again,

      • Scott Lahteine

        Scott Lahteine - 2009-04-04

        Hi Aaron,

        If you need the source code you need to check it out from sourceforge using CVS. They include documentation on how to do this on the site.

        • Aaron

          Aaron - 2009-04-04

          Thanks for your reply.  I finally figured out how to get my tablet working with Tablet Magic b16.  I have to limit the Tablet surface area to the upper left corner using the numerical values in the Mapping Pane, but I have found this to be a preferable option...strangely enough.

          I learned quite a bit by migrating to Linux for short time to play with the linuxwacom drivers.

          GIMP 2.6 reads pressure events using the XQuartz release of X11.

          Inkscape 0.46 does not, but that is their issue.

          Thank you so much.


    • Nobody/Anonymous

      The keyspan adapter arrived today---Keyspan USA-19HS

      I installed the Keyspan Drivers, reinstalled TabletMagic 2.0b16.

      As before, I have largely solved the jumpy cursor issue.  There seems to be no change with the Keyspan Adapter.  When TabletMagic recognizes my  Wacom Intuos GD 1212-R, it recognizes my screen size of 1680x1050 as 1599 x 1049, which means that the right edge of my screen is inaccessible to the cursor.  If I change any of the settings at all I have to uninstall TabletMagic, unload the kext files, receipts and preferences and restart.

      Could this have anything to do with the fact that the origin for screen drawing on the Mac is the upper left corner?  I'm guessing in the wind.

      Scott---you suggested that trying earlier versions might work.  I found b15 but nothing earlier, any suggestions on where to find earlier versions or what version to try...educated guess?

      Thanks for any help.


    • Nobody/Anonymous


      Is there anyway to use something like the "xsetwacom" command in a terminal window, like in Linux?

      I am bringFire (not logged in).  I loaded openSUSE 11.1 onto my Mac and played with the LinuxWacom drivers...the command line interface was an excellent way to trouble shoot....unfortunately Linux is limited on the software side...and hardware interface is really a challenge.

      Does TabletMagic have any kind of command line possibilities?



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks