Mailadresses dont work

2008-01-05
2013-05-02
  • Nobody/Anonymous

    The appearance of mailadresses in mailprogram (Gmail, I know its not a software) contains html-stuff like '%40' for @ (add) and cant be used. Can I do anything about it? Is it because its gmail?

    Fred

     
    • katzlbt

      katzlbt - 2008-01-07

      You need to convert the %40 to @ before adding the email address to TAB. Otherwise TAB will preserve the % HTML encoding and the addresses do not work. Can you post an example (not real) email address here and describe what you do?

       
    • Nobody/Anonymous

      I write the email-adresses as I know them. Not in html. It is when it makes the mailto call in TAB, that the email suddently appears with the html encoding. Funny, isnt it?

      I really like the TAB2 - I therefore began a translation in the trunk-svn into danish, because im interesseted in using it in danish. But im not shure how to upload the new translation file. Have you recieved something like dk.lang online?? Just a question...

      Fred

       
      • katzlbt

        katzlbt - 2008-01-09

        Ok, to help me with this problem, please let me know which browser you are using. It may be the browser that needs special treatment.

        Emails are obfuscated to avoid spammers to harvest them in case someone uses TABR without password on the internet.

        To disable obfuscation edit EmailHelper.class.php and remove 3x StringHelper::obscureString(xxx) with xxx

        If you have a sourceforge account post a feature request.
        If not send it to my sourceforge email (@users.sourceforge.net) as zip attachment.

        Thanks for your help!

         
    • Nobody/Anonymous

      OK, thanks. I will look into it asap. Im using firefox, and I have the problem on my Gmail (browser-based mail).

      Fred

       
      • katzlbt

        katzlbt - 2008-01-10

        Hmmm, so what you are saying is that you click an email in TABR that opens automatically in Gmail?
        Or do you transfer by copy and paste?

         

Log in to post a comment.