Getting SynCE to work on Mac OS X (10.3.5)

Help
2004-08-24
2013-05-23
  • Nobody/Anonymous

    I have just succeeded in getting SynCE to compile on a machine running Mac OS X and thought I would share the few adjustments that I had to make.

    I don't actually know if it will work yet, but it did at least compile and install okay.

    System:
    Darwin Kernel Verson 7.5.0

    SynCE Version: 0.9.0

    synce-libsynce:
    add the following as line 8 of synce_socket.h:
    #define OS_INLINE static __inline__

    (this fixes the problem with OSByteOrder.h that I've seen on the list once or twice)

    synce-librapi2:
    remove all occurances of '-Werror' from the Makefiles (I did this manually after configuration)

    libmimedir:
    add '-fno-common' to CFLAGS (again, I did this manually by editting the Makefile)
    after running make and getting an error, do:
    ranlib libmimedir.a
    and then rerun make.
    After running 'make install' execute the ranlib command again on the installed library:
    cd /usr/local/lib; ranlib libmimedir.a

    [it compiles fine without the '-fno-common' option but then rra fails to compile]

    synce-rra:
    Remove all occurences of -Werror

    As I said, I haven't actually tested the installation so there maybe hidden details that I have yet to discover, but the above changes at least meant that it compiled.  Also, not being a programmer, I made these changes manually but I suspect someone with more nonce could do it automatically.

    Andrew

     
    • David Eriksson

      David Eriksson - 2004-08-24

      Andrew,

      Thank you for your instructions! I will link to them from http://synce.sourceforge.net/synce/macosx.php so that other Mac OS X users can find them.

      Maybe I can use them to make the next version of SynCE a little more Mac OS X-friendly too! :-)

      If you feel like it you could mail me compile logs so I can investigate the warnings that made you remove -Werror.

      \David

       
      • Nobody/Anonymous

        Yep the instructions worked fine. I followed the advice on the homepage and then compiled using the msg instructions.
        Its important in the librapi to go into all subdirectories and remove the Werror as shown, I missed a few to start with and scratched my head a bit.
        Havent' been around a while, but it compiled fine on osx server 10.3.5 and connects to a Belkin PDA adaptor I had lying around. Connects to my E105. Will see if I can get my old code working as I'd like to connect my old device to OSX address book, etc.
        One thing, if I call synce-serial-start, it makes a connection and then after a few secs drops it, unless you call a command such as pls, then its fine.
        cheers
        Didz

         
        • Nobody/Anonymous

          as usual, problems cropped up :(
          pstatus pls etc work fine
          pcp seems fine on small files and then if i try to copy something useful I get ...
          didz$ pcp PocketPlayer.exe
          pcp: Failed to write to destination file ':\My Documents\PocketPlayer.exe'

          This occurs after a delay.
          any ideas, Im ot sure where to look
          pcp PocketPlayer.exe

          In system.log I can see..
          acscp: timeout sending Config-Requests

          cheers
          didz

           
        • Nobody/Anonymous

          Is it possible to connnect ipaq with powerbook (Mac OSX) using bluetooth ?
          Antoine

           
    • matthias jahn

      matthias jahn - 2004-08-30

      I have tried to compile it with those suggested workarounds.
      Hardware:
      IBook G3 600Mhz (OSX 10.3.5)
      HTC Walleby
      USB

      1. The USB Driver(LoolixUSBPocketPC) was not able to detekt the MDA so i patched it a litle.
      New deviceID und vendorID add in file project.pbxproj (line 231) :
        <key>HTC Wallaby</key>
        <dict>
         <key>CFBundleIdentifier</key>
         <string>com.loolix.driver.LoolixUSBPocketPC</string>
         <key>IOClass</key>
         <string>LoolixUSBPocketPC</string>
         <key>IOKitDebug</key>
         <integer>65535</integer>
         <key>IOProbeScore</key>
         <integer>1000</integer>
         <key>IOProviderClass</key>
         <string>IOUSBDevice</string>
         <key>IOTTYBaseName</key>
         <string>htc</string>
         <key>IOTTYSuffix</key>
         <string></string>
         <key>idProduct</key>
         <integer>206</integer>
         <key>idVendor</key>
         <integer>2996</integer>
        </dict>

      2. The librapi2:
      synce-librapi2-0.9.0 root# make
      make  all-recursive
      Making all in src
      Making all in support
      if /bin/sh ../../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../..   -no-cpp-precomp -I/sw/include -g -Wall -Wsign-compare -Wno-long-long -Werror -ansi -g -O2 -no-cpp-precomp -I.. -g -O2 -MT rapi_buffer.lo -MD -MP -MF ".deps/rapi_buffer.Tpo" -c -o rapi_buffer.lo rapi_buffer.c; \
      then mv -f ".deps/rapi_buffer.Tpo" ".deps/rapi_buffer.Plo"; else rm -f ".deps/rapi_buffer.Tpo"; exit 1; fi
      mkdir .libs
      gcc -DHAVE_CONFIG_H -I. -I. -I../.. -no-cpp-precomp -I/sw/include -g -Wall -Wsign-compare -Wno-long-long -Werror -ansi -g -O2 -no-cpp-precomp -I.. -g -O2 -MT rapi_buffer.lo -MD -MP -MF .deps/rapi_buffer.Tpo -c rapi_buffer.c  -fno-common -DPIC -o .libs/rapi_buffer.o
      rapi_buffer.c: In function `rapi_buffer_send':
      rapi_buffer.c:501: warning: assignment from incompatible pointer type
      make[3]: *** [rapi_buffer.lo] Error 1
      make[2]: *** [all-recursive] Error 1
      make[1]: *** [all-recursive] Error 1
      make: *** [all] Error 2

      I removed all -Werror  and the make and make install runs but:
      error:
      /usr/local/bin/pcp: Unable to initialize RAPI: An unspecified failure has occurred

      No Higher Level Application but synce-serial-start works.
      My PDA closed connection after 2 min with "no Desktop connection..".

       
    • matthias jahn

      matthias jahn - 2004-08-30

      Yes i have  followed  those instructions.
      But you want to know:
      >If you feel like it you could mail me compile logs so I can investigate the warnings that made you remove -Werror.

      So i have put the logs in my MSG.

      What i have forget to say.
      The "dccm -f -d 4" say nothing expect awaiting connection on Port XXXX (i do not remember)

      I think the is a little Endian  problem in the  librapi2.
      In line  "501 : warning: assignment from incompatible pointer type " .

      I can build and install the lib librapi2   if i remove all -Werror in the Makefiles.

      Steps after installation i have made:
      1. (as root) synce-serial-config /dev/tty.htc
      2. start dccm (later dccm -f -d 4)
      3. (as root) sync-serial-start
      4. pls or plstatus or somethin else all with the :
      "Unable to initialize RAPI: An unspecified failure has occurred" Error

      I do not have the hardware at the moment so i can not
      test more. Sorry.

       
      • Anurag Khare

        Anurag Khare - 2009-03-19

        Hi,
           I have downloaded synce-0.9.0.tar
           I have installed libsynce,rapi2,rra,libmimedir, now two modules remaining dccm and synce-serial.
           these modules are needed(install) for MacOSX ?.
           if its required how can i install.
           can someone help to install this on MacOSX.

        Thanks.
              

         
    • matthias jahn

      matthias jahn - 2004-08-31

      It works!!
      " /usr/local/bin/pls         
      Directory              Wed Jun 11 00:01:58 2003  Privat/
      Bus error "

      The problem was the FW

       
      • David Eriksson

        David Eriksson - 2004-08-31

        Good, now you have your connection!

        However, "Bus Error" sounds like an alignment problem somewhere!

        \David

         
    • matthias jahn

      matthias jahn - 2004-08-31

      Thanx for your help.

      >However, "Bus Error" sounds like an alignment problem somewhere!
      Any Idea how to track it down?

       
    • Mike Z

      Mike Z - 2005-02-22

      Newbie here.. I was able to DL and compile 0.9 using the instructions from this thread (carefully read twice, and caught by having to edit Makefiles in the src/support subdirectory), but all is compiled.. under 10.3.8 (on a G4/800).

      I've downloaded and installed the Loolix USB driver.

      I also have Missing Sync installed... and wondering if I need to uninstall that.

      I have a Dell Axim x50v, USB cradle, and have inserted the Dell into the cradle.

      I do not see anything in /dev that speaks to me :)

      I've also done an ipfw flush (for the short term debug).

      serial-start fails, and says I need to run serial-config

      So I guess I'm dressed up, but have no where to go yet :)

      Thanks for any help,
      Mike

       
      • David Eriksson

        David Eriksson - 2005-02-22

        Mike,

        May I ask why you try to use SynCE when you have The Missing Sync? You are probably right that you need to uninstall it.

        \David

         
        • Mike Z

          Mike Z - 2005-02-22

          Fair question :)

          I'm simply not crazy about it, and have done enough DB manipulation in my life that I thought I'd see what tools I could find to roll my own.  I'm not at all happy with the sync-logic that is used, and assuming synce will give me access to the PIM dbs on the PPC, I figure I can do better.

          Now assuming I uninstall MS, I should be seeing a new entry under /dev when I plug in the Axim?  Then I use that with the config command?

          Thanks,
          Mike

           
          • David Eriksson

            David Eriksson - 2005-02-22

            Hi,

            In that case I have an idea on how to combine The Missing Sync and SynCE.

            1. Compile and install these SynCE modules:

            libsynce
            librapi2

            2. Disable any password protection on your device

            3. Connect your device and find out its IP address (maybe an ifconfig ppp0 does the trick? I'm not familiar with Mac :-)

            4. In your home directory, create the subdirectory ".synce" and a text file called "active_connection" with the following contents:

            [dccm]
            pid=MYPID
            [device]
            ip=MYIP

            Replace MYPID with the pid of any running process. (Don't ask :-)

            Replace MYIP with the IP of your connected device.

            If the IP changes between different connections, update this file accordingly.

            5. Try the p-tools (http://synce.sourceforge.net/synce/tools.php). If they work, you can do anything you like with the database functions in librapi2. (I hope they work, because otherwise something is wrong or missing in my instructions above.)

            Good luck!

            \David

             
            • Mike Z

              Mike Z - 2005-02-22

              Works like a charm.

              Now my mission is to figure out how to peek and poke this thing.

              2 unrelated question...

              a) am I using the Loolix USB driver (for Mac OS X) at this point, or just piggy backing on MS?

              b) I've done an initial search, but am coming up empty handed... is there a set of starter info on how to get at the PIM databases?  I've grabbed the perl-wrappers (since Perl is my language of choice (please don't hate me Python lovers)), an of course am fighting that compile (but working on that... really I'm not as stupid as I look :) )... but don't see anything obvious in the tools list of how to get at the DBs.

              thanks,
              Mike

               
    • Nobody/Anonymous

      Can someone make a working Mac installer - package or .dmg ... please!

      If someone is already hosting the files somewhere I would really appreciate a link.

      By the way - I have a Windows Mobile 5 Dell Axim X50v, if that makes a difference.

      Thanks

       
    • Anurag Khare

      Anurag Khare - 2009-03-19

      Hi all,

      I have downloaded SynCE0.9.0 but

      SynCE instractions are not available now,

      http://synce.sourceforge.net/synce/start.php
      http://synce.sourceforge.net/synce/macosx.php

      can any one send me SynCE build instractions for MacOSX.

      Thanks

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks