3.1.10 - reload a table in a wild card set

Rick Otten
2012-12-10
2012-12-12
  • Rick Otten

    Rick Otten - 2012-12-10

    I'll test this with 3.1.11 and 3.2-snapshot shortly if I get the time this afternoon. (Since I want to upgrade my 3.1.10 instances to one of those anyhow.)

    I set up to replicate an entire schema with a wild card trigger. That part is working well.

    I decided to force a reload of one of the smaller tables covered by the wild card trigger. I used the mx4j interface. Whether I overload the initial load select value or not, I get the same error in the web interface:

    Error during MBean operation invocationMessage: RuntimeException thrown in RequiredModelMBean while trying to invoke operation reloadTable
    

    I don't see any errors in the logs.

    Instead, I get a 'synchronizing triggers' event.

    When I run it from symadmin it doesn't throw any errors. I never see an associated reload channel batch in sym_outgoing_batch though.

    Do reloads of individual tables not work when you use wild card triggers?

     
  • Rick Otten

    Rick Otten - 2012-12-10

    I didn't mean to put this in the 'mobile development' topic. Sorry about that. I'm not sure how to move it to the 'help' topic.

     
  • Rick Otten

    Rick Otten - 2012-12-12

    I tested this with 3.1.11.1 and 3.2.0-52. This issue is present there as well. I'll open an actual issue for it. Thanks.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks