the S60v3 doesn't work on the Nokia N95

Help
rux0r
2007-04-17
2013-04-25
  • rux0r

    rux0r - 2007-04-17

    Does anyone have any suggestions as to how one might get oggplay working on the N95?

    Have installed it and also the 320x240 and 240x320 skins, but I get the error message "Ogg Error: 2:-12" and I have no idea what that might mean

     
    • rux0r

      rux0r - 2007-04-20

      And, for what it's worth, there doesn't seem to be a mention of that particular error message anywhere else on these forums.  Could anyone who has a bit of knowledge of the code perhaps suggest what this error message might mean?

       
    • The Dark Rabbit

      The Dark Rabbit - 2007-05-08

      I'm having the same problem on an N93i.

       
    • jemm4jemm

      jemm4jemm - 2007-05-13

      I confirm this error message also with N95 firmware V 11.0.026

       
    • jemm4jemm

      jemm4jemm - 2007-05-13

      Well, in fact this page refers http://symbianoggplay.sourceforge.net/S60V3.html to pretty similar error message "OggPlay 2, -1 error" and advises to install right size skin (mcNuOggPlayQVLS.SIS should be for N95 240x320 pixel screen). I don't know how rux0r has done it, but in my case phone complains about expired certificate.

       
    • John

      John - 2007-05-15

      I got the same error on trying to run the installed OggPlay.
      The screen resolution is 230 x 320

      My N95 is latest firmware 11.0.0.026.
      I installed OggPlayS60V3_1_70.SIS
      I installed mcNuOggPlayQVGA.SIS and received an error Expired certificate.

      I then tried to run OggPlay from the installed Icon and received the error message "Ogg Error: 2,-12"

      Please help.

       
    • stig

      stig - 2007-05-16

      As far as I can see from install/OggPlay.s60V3MMF.pkg, there's no entry for the N95 MachineUID, so no skin will be installed. If you can manage to install mcNuOggPlayQVGA.SIS (by resigning or whatever), it'd probably work (I've never seen a .pkg file before in my life, though, so maybe not).

      BUT: I got the same error message, didn't bother to try to fix it, and uninstalled oggplay (after rebooting, otherwise I'd get a "file in use" message). Since then, the built-in web browser's fonts don't work - all characters are tiny squares. This is somewhat annoying. I can't be 100% certain OggPlay is the problem, of course, but post hoc etc...

      I haven't found a fix yet, and I'll probably end up reformatting with fingers well crossed, but for now you probably shouldn't install OggPlay on the N95.

      Oh, and if anyone has a fix... :)

       
    • stig

      stig - 2007-05-16

      For the time being, I've reinstalled OggPlay, and the web browser now works. The font is twice the width it was before, but I can live with that, at least for a while.

       
    • Jan Schubert

      Jan Schubert - 2007-05-16

      Same here for my E61i

       
    • Stuart Fisher

      Stuart Fisher - 2007-05-16

      I've been quiet for some time as I've really not had any time to work on OggPlay lately.

      The -12 error means directory not found. As someone has pointed out this probably means that there is no skin installed.
      I suspect the error Expired certificate is also related to the missing directory.

      In order to solve the problem you need to do the following:

      1. Install OggPlay to a memory card (Either version, S60V3 MMF or non-MMF, it doesn't matter which)
      2. Take the memory card to a PC (or MAC) and fix the directory structure:
      \private\F000A661
      \private\F000A661\import       (I think this directory is the one that is missing. Use the PC to create it)

      3. Put the memory card back in the phone and install the QVGA skin (the portrait one, not the landscape one).
      4. Start OggPlay. This time it should work, although I haven't tried it so I can't say for sure.
      5. Do not change the device screen orientation when OggPlay is running. OggPlay doesn't support that yet.

      Regarding the fonts:
      S60V1 and S60V2 phones all used the same font: Latin12
      Consequently almost all existing OggPlay skins use this font.

      On S60V3 the Latin12 font does not exist anymore. Furthermore all of the new phones use different fonts.
      Consequently I decided that the best solution would be to install our own fonts. It was either that or create a different skin for each phone model.

      Unfortunately the fonts are not automatically detected by the font server after installation, so a reboot is required for the skin to look right. A minor problem, not a big deal.

      Worse though, is that the fonts are not automatically released when OggPlay exits, so it becomes impossible to uninstall the fonts without also rebooting the phone (which obviously does release the fonts). I don't know why Symbian do not release the font locks. They could have unlocked the font files if they were not in use but they didn't.

      It's also possible that the installing and uninstalling of the fonts is affecting the web browser as you have discovered. But as you can see from the .pkg file we only install and uninstall our own fonts. Why on Earth installing some fonts would mess up your web browser I have no idea. Another Symbian/Nokia bug perhaps!?

       
    • Jan Schubert

      Jan Schubert - 2007-05-16

      Just try this: Install OGG and afterwards a Theme (because there might no Theme be installed if your phone is not recognized). If you get any certificate error while installing just set your date (in the phone) back to 2006. Switch back after installing. Worked fine for my E61i.

       
    • stig

      stig - 2007-05-17

      Stuart and longint2, thanks for your suggestions. I've managed to get my web fonts back, by messing around with the memory card in a PC for a while. It seems ProFontWindows.ttf in e:/resource/fonts was the one the browser insisted on using, so I tried renaming that, but ended up with squares again. Next, I copied the normal s60 system font (nohindisnr60.ttf) from the phone (z:/resource/fonts) to the card, and renamed it Pro... on a PC. This led to the browser using this font for most text, but not for buttons (probably because the text is bold, which the normal system font isn't). I can't remember the exact sequence of resetting, memory card removing and font removing that followed, but I think suspect that all that's necessary is to restart the phone with no memory card, and then possibly removing the fonts from the /resource/fonts folder on the memory card. I also assume that the renaming I did was not necessary, but it did help me understand a bit of what went on.

      In a while, I'll try to reinstall OggPlay, since I know think I know how to get the right fonts back, and I'll try the above workarounds.

       
    • rux0r

      rux0r - 2007-05-17

      Well I've managed to get it working - although I didn't do things exactly as you suggested.

      I changed the date to a year ago to cater for the skin certificate

      I then installed OggPlay to the memory card
      I then installed the OVGA skin to the memory card
      I then took out the memory card to see if I could fix the directories, but to my surprise they were already there
      I then put the card back in the N95 and it worked fine.

      So could it be the case that there's just a problem installing to the standard phone memory, whereas installing to the memory card is OK?

       
      • Jan Schubert

        Jan Schubert - 2007-05-17

        I just use my meory card. There is just toooo less memory built in :-).

         
    • Stuart Fisher

      Stuart Fisher - 2007-05-17

      The expired certificate doesn't make any sense to me. All of the sis files (including OggPlay itself) are self signed with a certificate that shouldn't be expiring. But if changing the date allows you to install the skin then that's great. Installing to the phone memory shouldn't be any different to installing to a memory card, so that doesn't make sense either :-(

      The fonts thing is very strange. I don't know why the web browser has decided to use ProFontWindows. It's a freeware font that I wouldn't expect it to try and use! Nevertheless what I will do for the next release is change the name of the font to OggPlayProFontWindows.ttf and change the names of the other fonts too. That way if the web browser still has problems it most definitely won't be the fault of OggPlay.

       
    • marko60

      marko60 - 2007-06-13

      Hi everyone - new member here! Thanks to the helpful advice on this thread, I finally installed Oggplay on my n95 . . and managed to reinstate the web browser font after the process mysteriously implemented its own! ;)

      One question. How do I get the player to search for new tracks only in E:\ogg? Whenever I try, the phone tells me "Cannot open directory E:\Ogg\" I've tried to create a directory with that name, but the creation process won't seem to allow characters like : or \

      At the moment, a full scan of my files throws up quite a few unwelcome additions. I'd prefer to keep things tidy by just uploading music tracks to a dedicated ogg directory. Thanks in advance . . and for all your inadvertent help so far! :)

       
    • marko60

      marko60 - 2007-06-15

      Hello again, just realised in a blinding flash the stupidity of my question posted above. Duh. Have now created directory named simply Ogg in the E drive of my phone and, guess what? Thanks again for the guide to installing the player!

       
    • marko60

      marko60 - 2007-08-31

      Right. Having got the player to work on my n95, I'm now trying for gapless playback for listening to albums like Dark Side of the Moon. I've downloaded an updated version of CDex which converts the CD into one long ogg file (using so-called partial extraction.) It also produces a Cue Sheet. However, having downloaded both on to my phone, there is no track listing for the album - albeit that the album is suitably gap-free. This is not ideal, as you'll appreciate. I imagine the answer lies with correct implementation of the Cue Sheet. Can any kind soul tell me  how I am supposed to use this feature to achieve the desired effect? Thanks, again, in advance.

       
  • ^m'e

    ^m'e - 2011-08-24

    Hi there,
    I installed today OP-v1.72 on my n95-8GB firmware 35.0.001 (as of today, still the latest available). It works like a charm and finds files in the standard 'E:/Sounds' directory - no longer necessary having an 'E:/Ogg' directory.
    I'd really love binding the controls to the custom hardware buttons, so that I can get rid of the slow and clumsy original Music Player app!

    Kudos to developers!

    ^m'e

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks