problems with sel/list fileset and run

2012-02-15
2013-01-06
  • The New Fall Guy

    Hi

    I tried to run the following command
        sfk list -fileset fileset.sfk +run "echo ((($file)))" -yes
    and all it does is list the files as if I had not specified the +run option

    I then tried
        sfk sel-fileset fileset.sfk +run "echo ((($file)))" -yes
    and got:
    error: sel requires dir- or filename parameters.

    Can somebody tell me what I am doing wrong?

    Here is the content of fileset
    -dir Web
    !\FTP\
    !\PHP\

     
  • stahlworks

    stahlworks - 2012-02-15

    The -fileset option is currently very primitive.
    - it does not support command chaining at all
    - it must be specified as the last option of a command,
      and nothing is allowed to follow after -fileset.

    So all you can do is a workaround like
    1. create a file with all filenames of interest by

    sfk list -tofile mylist.txt -fileset myfileset.txt
    

    2. then use that file in a second command like

    sfk filter mylist.txt +run ...
    
     

Log in to post a comment.