We've been able to use SWIG 2.0.10 to target Python 3.3 and 3.4 successfully. I'm not entirely sure what this release note is referring to, "Python 3.3 support completed."

Note, Python 3.x is much more binary compatible as well. On Linux, we build against Python 3.3 and integration test against Python 3.4. We weren't successful on Windows with the binary compatibility unfortunately. Ultimately, we'll need SWIG to generate a Py_LIMITED_API compatible wrappers to guarantee compatibility across all Python 3.x, theoretically not requiring an upgrade to SWIG to support new versions of Python. 

-Brian

From: Olivier Voyer <olivier.voyer@gmail.com>
Date: Wednesday, July 23, 2014 1:08 PM
To: Swig User List <swig-user@lists.sourceforge.net>
Subject: [Swig-user] Python 3.4

Does SWIG support Python 3.4 yet? I only see support for Python 3.3 in the latest release notes.

--
Olivier