Autoconf 2.60 release notes says AC_PROG_SED was introduced in autoconf 2.60: http://git.savannah.gnu.org/cgit/autoconf.git/tree/NEWS.  See also https://issues.asterisk.org/view.php?id=8345 for a similar problem.  Tools/config/ax_path_generic.m4 uses AC_PROG_SED.

 

We should either increase the min autoconf version, or add some backward compatibility.

 

Would this be enough to hard-code sed?  Say, dropped in Tools/config/ax_path_generic?

 

AC_DEFUN([AC_PROG_SED], [ SED=sed ])

 

$ ./autogen.sh

+ test -d Tools/config

+ aclocal -I Tools/config

configure.in:75: warning: AC_PROG_SED is m4_require'd but is not m4_defun'd

configure.in:75: AC_PROG_SED is required by...

Tools/config/ax_path_generic.m4:142: AX_PATH_GENERIC is expanded from...

configure.in:75: the top level

+ autoheader

configure.in:75: warning: AC_PROG_SED is m4_require'd but is not m4_defun'd

configure.in:75: AC_PROG_SED is required by...

Tools/config/ax_path_generic.m4:142: AX_PATH_GENERIC is expanded from...

configure.in:75: the top level

+ automake --add-missing --copy --force-missing

configure.in:75: warning: AC_PROG_SED is m4_require'd but is not m4_defun'd

configure.in:75: AC_PROG_SED is required by...

Tools/config/ax_path_generic.m4:142: AX_PATH_GENERIC is expanded from...

configure.in:75: the top level

configure.in: installing `Tools/config/install-sh'

configure.in: installing `Tools/config/missing'

Source/Makefile.am: installing `Tools/config/compile'

Source/Makefile.am: installing `Tools/config/depcomp'

+ autoconf

configure.in:75: warning: AC_PROG_SED is m4_require'd but is not m4_defun'd

configure.in:75: AC_PROG_SED is required by...

Tools/config/ax_path_generic.m4:142: AX_PATH_GENERIC is expanded from...

configure.in:75: the top level

configure:4358: error: possibly undefined macro: AC_PROG_SED

      If this token and others are legitimate, please use m4_pattern_allow.

      See the Autoconf documentation.

 

auto-tools are locally built.  Versions:

 

aclocal 1.9.5

autoheader 2.59

automake 1.9.5 (>= 1.7.2 as spec in www.swig.org/svn.html)

autoconf 2.59 (>= 2.58 as spec in www.swig.org/svn.html)

 

--

-Justin