Sorry for the delay, I am not forgetting you.
I'am setting up a Xubuntu machine to reproduce your problem. Maybe it will be simpler that way.

Could you give me some details on your configuration ?
- Xubuntu version (and architecture)
- compiler used and version, autotools version
- do you use a compiled version of Scilab or an installed version
- etc..  : any information could be use useful

Thank you.


Le 30/11/2013 03:28, Ian Bell a écrit :
Is this something that I can do?  If so, can you provide directions?  I'd really like to get SWIG+Scilab working, and I have a pretty standard config, so I suspect others would run into similar problems.

On Mon, Nov 25, 2013 at 12:25 PM, Simon Marchetto <simon.marchetto@scilab-enterprises.com> wrote:
That's strange, configure always generates a config.log, doesn't it ?

We have to reproduce manually the configure of the compiler, I mean outside of Scilab and in the same conditions, to get that log.
Without it, it is difficult to know what's going wrong, wrong include path ? etc....

I'll send you a configure file.

Le 23/11/2013 22:36, Ian Bell a écrit :
There's no config.log in the examplelib folder, but there is a unix.err file (attached) in the TMPDIR root directory.

On Fri, Nov 22, 2013 at 5:12 PM, Simon Marchetto <simon.marchetto@scilab-enterprises.com> wrote:
Scilab runs an internal configure, and this one fails in configuring of compiler.

To have more information on this, execute manually the script builder.sce in Scilab.
After it fails, still in Scilab:
- check the value of TMPDIR. 
- in the subdirectory examplelib of directory pointed by TMPDIR, you should find the configure log config.log.
It should contain the detailed error message.


Le 22/11/2013 15:25, Ian Bell a écrit :
Ok, this time with brain installed.  Log file attached for build process of simple example.


On Fri, Nov 22, 2013 at 12:44 PM, Simon Marchetto <simon.marchetto@scilab-enterprises.com> wrote:

make SWIGOPT="-vbl 2" >foo.log 2>&1

to redirect all the output with maximum verbosity to foo.log

Le 22/11/2013 11:11, Ian Bell a écrit :
I have tried to rebuild swig+scilab on xubuntu using absolute paths, and I get the same exact problem.  I also tried to call ilib_verbose(2) before running "exec builder.sce", but I don't get any more useful information than the above.  FWIW, here is my build script:

git clone https://github.com/swig/swig -b gsoc2012-scilab swig-scilab
cd swig-scilab
sh autogen.sh
./configure --with-scilab-inc=/home/xubuntu/Desktop/scilab-5.4.1/include --with-scilab=/home/xubuntu/Desktop/scilab-5.4.1/bin/scilab --disable-ccache

How can I further debug this error? 


On Fri, Nov 22, 2013 at 10:40 AM, Simon Marchetto <simon.marchetto@scilab-enterprises.com> wrote:
First, I never tried SWIG Scilab on OSX. For now, SWIG Scilab is supposed to run only on Linux, it is mentioned now in the documentation page. We'll try to support other platforms in the (near ?) future.

But, let's have a look at your problem. On OSX, it is clear that your configure failed when finding scilab.
I suspect the tilde in (in ~/Desktop) to be the source of problem. Could you try again with an absolute path /home/.... ?
And if this errors occurs again, please send us the log of configure (config.log).

For Xubuntu, maybe we have the same issue, I am not sure. Could you test also a configure with an absolute path ?


Le 21/11/2013 23:49, Ian Bell a écrit :
No good on linux or OSX.  New errors now...

Trying on xubuntu, I build swig with

git clone https://github.com/swig/swig -b gsoc2012-scilab swig-scilab
cd swig-scilab
sh autogen.sh
./configure --with-scilab-inc=~/Desktop/scilab-5.4.1/include --with-scilab=~/Desktop/scilab-5.4.1/bin/scilab-cli --prefix=/home/xubuntu/Desktop/swig-bin --disable-ccache

then cd swig-scilab/Examples/scilab/simple

when I run make, I get

Scilab 5.4.1 (Mar 29 2013, 16:52:15)
 !--error 10000
ilib_gen_Make: An error occurred during the detection of the compiler(s). Set ilib_verbose(2) for more information.
at line      24 of function generateConfigure called by : 
at line      56 of function ilib_gen_Make_unix called by : 
at line      49 of function ilib_gen_Make called by : 
at line      99 of function ilib_build called by : 
  ilib_build(ilib_name, table, files, libs, [], ldflags, cflags);
at line      24 of exec file called by :   
Argh! Am I doing something wrong? Or is it not working properly?

OSX, same problem:

Ians-Mac-mini:Desktop Ian$ cd swig-scilab/Examples/scilab/simple/
Ians-Mac-mini:simple Ian$ make
make -f ../../Makefile SRCS='example.c' SWIG='../../../preinst-swig' \
TARGET='example_wrap.c' INTERFACE='example.i' scilab
../../../preinst-swig  -scilab  -addsrc "example.c" example.i
if [ -f builder.sce ]; then \
env LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH MAKEFLAGS="-j1"    -f builder.sce; \
env: -f: No such file or directory
make[1]: *** [scilab] Error 127
make: *** [build] Error 2


On Sun, Nov 17, 2013 at 12:17 AM, Ian Bell <ian.h.bell@gmail.com> wrote:
I'm away from my development computers right now, but I will let you know as soon as I get home whether I can get the examples to build properly now.  *fingers crossed*.

And then on to my own code.


On Fri, Nov 15, 2013 at 12:25 PM, Simon Marchetto <simon.marchetto@scilab-enterprises.com> wrote:
Le 13/11/2013 19:43, Ian Bell a écrit :

That macro definition seems to be part of the problem, but there do seem to be quite a lot of usability issues with 5.4.1 and swig.  I would be very appreciative if you could take a look.  Ideally it would be great if you could run the SWIG test suite before you release a new version to be sure it isn't going to break things.


I had the same compilation error as you:

ilib_compile: An error occurred during the compilation:
In file included from example_wrap.c:759:0:
/home/ian/Desktop/scilab-5.4.1/share/scilab/../../include/scilab/stack-c.h:19:6: error: #error Using stack-c.h is deprecated. Please use api_scilab instead (try 'help api_scilab'). Note the stack-c.h API will be removed after Scilab 6.0. You can define __USE_DEPRECATED_STACK_FUNCTIONS__

I committed the fix that does the define of __USE_DEPRECATED_STACK_FUNCTIONS__.

With that fix, on an installed Scilab 5.4.1 on a Debian 7.10 x64, I successfully ran all the examples.
I ran also the test suite. The test suite has still yet some problems, essentially about typemaps, but these problems are known and are planned to be to fixed (I hope soon....).
For me 5.4.1 should run as same as 5.3.3, and master 5.5.

Could you give me some details about your issues ?


PS: the example in documentation (which comes from the simple example you are testing) was wrong, it did not run.
I fixed this, among many other things in the documentation, which was outdated (but there is still some work to do).

Development Engineer
Scilab Enterprises
143bis rue Yves Le Coz - 78000 Versailles, France
Phone: +33 1 80 77 04 71