On 26/07/12 21:24, Leif Middelschulte wrote:
On 24/07/12 23:24, Leif Middelschulte wrote:
Am Dienstag, 24. Juli 2012 um 11:20 schrieb Oliver Buchtala:
On 24.07.2012 07:52, William S Fulton wrote:
On 09/07/12 23:48, Leif Middelschulte wrote:
See sheet 3 of
for more details about nonworking language features in the C++
I think it's a pitty that many tests mix a lot of features in a single
interface file. That makes it hard to see which features work and
(combinations) don't for a certain backend.
Most of the tests are corner cases and yes mostly they expect a module
in good working order. If you think it will help, a set of very basic
C++ feature testcases could be added to the test-suite. Maybe ten or so
testcases all similarly named, eg cpp_basic_static_member_function.i,
cpp_basic_static_member_variable.i, cpp_basic_virtual.i etc.
I am missing such atomic basic test cases, too.
For the development of a new module this would invite to start using the
test-suite much earlier.
William's suggestions is fine.
Would you mind to add some to trunk so we students have common tests?
That would be very beneficial :) If you don't have the time, maybe we
can split things among students. We will need some kind of naming
convention like "cpp_featurename_basic.i" and
"cpp_featurename_advanced.i" or alike, won't we?
These should be called cpp_basic_xxx.i as I indicated above. I think anyone
needing to test a basic feature can do this. The interface file will
probably< 10 lines each! Here are a couple to get going. The runtime tests
should be obvious:
I've added a couple of basic tests. Though I put them in the "atomic"
namespace. Maybe I'll get to change it to "basic" later :)
I think this might be a translation into English misnaming as "atomic"
isn't right. When I saw "atomic" I immediately thought of the computer
science meaning to do with atomic operations in threading. Perhaps you
are trying to use the equivalent terms to "minimal" or "small" or
"minute" where I chose "basic"? Anyway, I see you have now renamed them,
thanks. If I had got around to sending this email this morning I was
going to suggest that perhaps cpp_minimal_xxx.i is a more clear and apt
name. But as you've already gone to the trouble of changing them, not to
worry and thanks again.