SourceForge has been redesigned. Learn more.
Close

#1113 'make -k check' fails for swig-2.0.1

closed-wont-fix
nobody
5
2011-02-05
2010-10-28
No

I am building 'swig' in the framework of my AppsFromScratch, the essence being that every target is built in and installed into a separate directory, with no 'root' privileges need.

'configure' is run using the to be attached autogenerated wrapper ('config_wrapper.sh' file) - one can see versions and locations of needed for 'swig' libraries.

I am about to upload 'make -k check' screen output.

Discussion

  • Sergei Steshenko

    autogenerated 'configure' wrapper used to build swig-2.0.1

     
  • Sergei Steshenko

    I can't upload the needed file - though its size is:

    -rw-r--r-- 1 sergei users 62474 2010-10-23 02:50 /home/sergei/junk/make_-k%20check.log.gz

    , sf.net tells me the file should be no larger than 256kbytes, and the file is no larger

     
  • Sergei Steshenko

    I've uploaded the file to a different place: http://file.qip.ru/get/jZjeoZNX/make_-k20check.html . It takes about 2 seconds for the "Download file now" link to appear - when it appears, click on it.

    I am mostly interested in OCaml and Perl failures fixed.

     
  • William Fulton

    William Fulton - 2010-10-28

    For Perl you are missing the boost library. Ocaml support has disappeared and has been broken for some time and will remain so until a new maintainer updates it. The same can be said for Guile which accounts for most of the other problems in your log.

     
  • Sergei Steshenko

    It's not me, but rather 'configure' who is missing 'Boost' library. I.e. 'configure' should have checked 'Boost' existence and if it is not found, it should have created the Makefile(s) in a manner that doesn't run the tests which depend on 'Boost'.

     
  • William Fulton

    William Fulton - 2011-02-05

    Boost is a prerequisite for the test-suite. We cannot fail at configure time if boost is not found because configure must work for users who don't care if boost is installed or not. This is one of the few additional dependencies that developers need in order to get the test-suite to work. The test-suite does indeed fail when boost is not installed. As it says in the top level README file, 'make check' may fail, but it doesn't necessarily mean there is a problem with SWIG and this is one of those cases.

     
  • William Fulton

    William Fulton - 2011-02-05
    • status: open --> closed-wont-fix
     
  • William Fulton

    William Fulton - 2011-02-05

    Also see #3173367

     

Log in to post a comment.