Apt Repository open

SticKK
2007-11-12
2013-04-08
  • SticKK

    SticKK - 2007-11-12

    I have just finished setting up an apt-repository. I still haven't figured out how to use my keys to sign the repository. So you will get an unauthenticated warning. Adding the one following lines, based on your version, to your repository list will allow you to use apt/synaptic/adept.

    Dapper
    deb http://download.tuxfamily.org/swiftweasel dapper main

    Edgy
    deb http://download.tuxfamily.org/swiftweasel edgy main

    Feisty
    deb http://download.tuxfamily.org/swiftweasel feisty main

    Gutsy
    deb http://download.tuxfamily.org/swiftweasel gutsy main

     
    • StratosL

      StratosL - 2007-11-12

      Great work, thanks. I've upgraded from 2.0.0.8 to 2.0.0.9

      Let us know when we can import your signature!

      StratosL

       
    • SticKK

      SticKK - 2007-11-13

      I have made some changes

      Dapper
      deb http://download.tuxfamily.org/swiftweasel dapper multiverse

      Edgy
      deb http://download.tuxfamily.org/swiftweasel edgy multiverse

      Feisty
      deb http://download.tuxfamily.org/swiftweasel feisty multiverse

      Gutsy
      deb http://download.tuxfamily.org/swiftweasel gutsy multiverse

       
    • Pac Shady

      Pac Shady - 2007-11-13

      There seems to be an error since changing your repo to include your GPG details. This is what I get at the end of my apt-get update:

      "Failed to fetch http://download.tuxfamily.org/swiftweasel/dists/gutsy/Release  No Hash entry in Release file /var/lib/apt/lists/download.tuxfamily.org_swiftweasel_dists_gutsy_Release"

      Not sure how to fix it or what causes it though, but I'd bet it's related to the GPG thing. I haven't bothered with GPG yet for my repo so haven't come across it :). Might need to ask for help in the TuxFamily IRC channel if you're not sure on what's going on.

      'Shady

       
    • Fraoch

      Fraoch - 2007-11-14

      I've tried this on two machines and get a 404 error every time?

      Is the repo up?

       
    • Pac Shady

      Pac Shady - 2007-11-14

      OK, not sure what happened, but this morning the multiverse repository worked well, seemed the problem I posted was fixed. Now however both the multiverse and the main repos are 404-ing. I checked your repository structure, and within the binary-i386 directory for Gutsy you've got an "untitled folder" in there which has the Release and Package files, which is preventing APT from getting to them.

       
    • SticKK

      SticKK - 2007-11-18

      The multiverse repository is the one to use. I have just added swiftdove to it.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks