Can't find mozilla runtimes in Gutsy 2.0.0.8

lingenfr
2007-10-28
2013-04-08
  • lingenfr

    lingenfr - 2007-10-28

    I found sw the other day and am pretty pleased. I used the deb for the 4m on my laptop (Toshiba Libretto U100) for 2.0.0.8 and it worked like a champ. When I tried to install the one for the Pentium 4 on my desktop, no joy. It appeared to install ok, but when I went to run it (from a cli since kde would not work), I got a bunch of permission errors and then it puked with an error that it could not find mozilla runtimes. I played with some simlinks, but no joy. I purged all firefox and mozilla (and sw) and tried again, same thing. So, I tried the 3.0 fork version and it works fine. I even tried to install the 2.0.0.8 version and copy the profile from the trunk version. All to no avail. I think that the package is hosed, but maybe it is my system. Any ideas? I googled around, but could not find anyone with a similar problem. Thanks.

     
    • lingenfr

      lingenfr - 2007-10-28

      I should add that it works when I use:

      sudo swiftweasel

      just not when I try it as a user. The trunk version is great, but I am pretty addicted to adblock, foxytunes and translator. Thanks.

       
    • lingenfr

      lingenfr - 2007-10-28

      The exact feedback:

      lingenfr@MPC-MBR:~$ swiftweasel
      esd: no process killed
      the settings directory exists
      Cannot find mozilla runtime directory. Exiting.

       
    • lingenfr

      lingenfr - 2007-10-30

      Bump.

       
    • SticKK

      SticKK - 2007-11-01

      Please provide the exact file name you installed.

       
      • lingenfr

        lingenfr - 2007-11-01

        I installed:

        swiftweasel-2.0.0.8_pentium-4_ubuntu-i386.deb

        Which was listed as being for Gutsy under the Stable branch.

         
    • SticKK

      SticKK - 2007-11-01

      Please provide the results of

      ls -al /usr/local/swiftweasel

       
      • lingenfr

        lingenfr - 2007-11-02

        lingenfr@MPC-MBR:~$ ls -al /usr/local/swiftweasel
        total 16092
        drwxr-xr-x 14 linglee linglee     4096 2007-10-28 13:34 .
        drwxr-xr-x 12 root    root        4096 2007-10-31 15:21 ..
        -rw-r--r--  1 linglee linglee        0 2007-10-21 04:23 .autoreg
        -rw-r--r--  1 linglee linglee      111 2007-10-21 04:23 browserconfig.properties
        drwxr-xr-x  3 linglee linglee     4096 2007-10-28 10:50 chrome
        drwxr-xr-x  2 linglee linglee     4096 2007-10-28 10:50 components
        drwxr-xr-x  5 linglee linglee     4096 2007-10-28 10:50 defaults
        drwxr-xr-x  2 linglee linglee     4096 2007-10-28 10:50 dictionaries
        drwxr-xr-x  8 linglee linglee     4096 2007-10-28 10:50 extensions
        lrwxrwxrwx  1 linglee linglee       11 2007-10-28 10:50 firefox -> swiftweasel
        lrwxrwxrwx  1 linglee linglee       15 2007-10-28 10:50 firefox-bin -> swiftweasel-bin
        drwxr-xr-x  2 linglee linglee     4096 2007-10-28 10:50 greprefs
        drwxr-xr-x  2 linglee linglee     4096 2007-10-28 10:50 icons
        drwxr-xr-x  2 linglee linglee     4096 2007-10-28 10:50 launchers
        -rw-r--r--  1 linglee linglee     2567 2007-10-21 04:23 LEGAL
        -rw-r--r--  1 linglee linglee      476 2007-10-21 04:23 libfreebl3.chk
        -rwxr-xr-x  1 linglee linglee   251480 2007-10-21 04:23 libfreebl3.so
        -rwxr-xr-x  1 linglee linglee   850608 2007-10-21 04:23 libmozjs.so
        -rwxr-xr-x  1 linglee linglee   214936 2007-10-21 04:23 libnspr4.so
        -rwxr-xr-x  1 linglee linglee   446036 2007-10-21 04:23 libnss3.so
        -rwxr-xr-x  1 linglee linglee   275648 2007-10-21 04:23 libnssckbi.so
        -rwxr-xr-x  1 linglee linglee    15676 2007-10-21 04:23 libplc4.so
        -rwxr-xr-x  1 linglee linglee     8688 2007-10-21 04:23 libplds4.so
        -rwxr-xr-x  1 linglee linglee   142000 2007-10-21 04:23 libsmime3.so
        -rw-r--r--  1 linglee linglee      476 2007-10-21 04:23 libsoftokn3.chk
        -rwxr-xr-x  1 linglee linglee   324328 2007-10-21 04:23 libsoftokn3.so
        -rwxr-xr-x  1 linglee linglee   159388 2007-10-21 04:23 libssl3.so
        -rwxr-xr-x  1 linglee linglee   110616 2007-10-21 04:23 libxpcom_compat.so
        -rwxr-xr-x  1 linglee linglee   768576 2007-10-21 04:23 libxpcom_core.so
        -rwxr-xr-x  1 linglee linglee     9448 2007-10-21 04:23 libxpcom.so
        -rwxr-xr-x  1 linglee linglee     9204 2007-10-21 04:23 libxpistub.so
        -rw-r--r--  1 linglee linglee    30869 2007-10-21 04:23 LICENSE
        -rwxr-xr-x  1 linglee linglee    12076 2007-10-21 04:23 mozilla-xremote-client
        -rw-r--r--  1 linglee linglee      117 2007-10-21 04:23 old-homepage-default.properties
        drwxr-xr-x  2 linglee linglee     4096 2007-10-28 10:50 plugins
        -rw-r--r--  1 linglee linglee     1897 2007-10-21 04:23 README-Swiftweasel
        -rw-r--r--  1 linglee linglee      184 2007-10-21 04:23 readme.txt
        -rw-r--r--  1 linglee linglee     6085 2007-10-21 04:23 README.txt
        -rwxr-xr-x  1 linglee linglee    13062 2007-10-21 04:23 removed-files
        drwxr-xr-x  6 linglee linglee     4096 2007-10-28 10:50 res
        -rwx------  1 linglee linglee    10492 2007-10-21 04:23 run-mozilla.sh
        drwxr-xr-x  2 linglee linglee     4096 2007-10-28 10:50 searchplugins
        -rwxr-xr-x  1 linglee linglee     5988 2007-10-22 07:56 swiftweasel
        -rwxr-xr-x  1 linglee linglee 12464176 2007-10-21 04:23 swiftweasel-bin
        -rw-r--r--  1 linglee linglee    18465 2007-10-21 04:23 swiftweasel-icon-license.txt
        -rwxr-xr-x  1 linglee linglee     6443 2007-10-22 07:56 swiftweasel-ran
        lrwxrwxrwx  1 root    root          13 2007-10-28 10:56 swiftweasl -> ./swiftweasel
        -rwxr-xr-x  1 linglee linglee    83856 2007-10-21 04:23 updater
        -rw-r--r--  1 linglee linglee      149 2007-10-21 04:23 updater.ini
        drwxr-xr-x  3 root    root        4096 2007-10-28 13:34 updates
        -rwxr-xr-x  1 linglee linglee    33024 2007-10-21 04:23 xpicleanup

         
    • SticKK

      SticKK - 2007-11-03

      Could you please try a different deb file of 2.0.0.8 to see if its just that one file?

       
      • lingenfr

        lingenfr - 2007-11-03

        Sure, which one do you suggest. I have Pentium IV machine.

         
    • SticKK

      SticKK - 2007-11-03

      Any of them, you can replace it aftwards if you want. The pentium-m would be a good choice though.

       
    • lingenfr

      lingenfr - 2007-11-03

      I tried it, no joy. I thought that I was on to something as gdebi was not asking me for the root password for the install. So I ran gdebi with sudo, but still no joy. When swiftweasel is run it is trying to right files to directories that are owned by root. That will never work and should be taken care of during the install run as su/root. Here is the output when I try to run swiftweasel as a user, then with sudo, then as a user again. When I run it with sudo it works fine. I don't really want to do an suid, etc. In the interim I am running iceweasel. I have the 4m version very happily running on a similarly configured machine. Don't know what is going on.

      lingenfr@MPC-MBR:~/Desktop$ swiftweasel
      esd: no process killed
      the settings directory exists
      mv: cannot move `/usr/local/swiftweasel/swiftweasel' to `/usr/local/swiftweasel/                                                                                                   swiftweasel-ran': Permission denied
      mv: overwrite `/usr/local/swiftweasel/swiftweasel', overriding mode 0755? y
      mv: cannot move `/usr/local/swiftweasel/swiftweasel-start' to `/usr/local/swiftweasel/swiftweasel': Permission denied
      Cannot find mozilla runtime directory. Exiting.
      lingenfr@MPC-MBR:~/Desktop$ sudo swiftweasel
      esd: no process killed
      the settings directory exists
      lingenfr@MPC-MBR:~/Desktop$ swiftweasel
      esd: no process killed
      the settings directory exists
      Cannot find mozilla runtime directory. Exiting.
      lingenfr@MPC-MBR:~/Desktop$

       
    • lingenfr

      lingenfr - 2007-11-08

      I'm sure everyone is busy, but this was taking far too long. There is an issue as trunk worked fine, none of the rest did. This machine was one that I got back from my oldest boy, so it may have been tampered with. I wiped it and reinstalled gutsy and switftweasel pentium 4. It works ok now.

       
    • SticKK

      SticKK - 2007-11-08

      Thanks for the update.

       

Log in to post a comment.