mailto: link fix for launching Thunderbird

BigDoug
2007-11-23
2013-04-08
  • BigDoug

    BigDoug - 2007-11-23

    I'm a desktop Ubuntu user, an average Joe, learning Linux, not a guru, not a qualified hacker, so perhaps someone more experienced may be kind enough to correct any errors here.

    After installing Swiftweasel the browser would no longer open “mailto:” links by launching  Thunderbird. Firefox developed the same problem.
    It may not be from installing Swiftweasel, because various forums report this problem with Firefox and Thunderbird not working together with mailto links in websites after updates.

    At some point my /usr/bin/mozilla-thunderbird  was changed to  /usr/bin/thunderbird (a link to a script in /usr/lib/thunderbird/thunderbird).  So first check /usr/bin and if you only have thunderbird and mozilla (which links to the script /usr/local/bin/swiftweasel32 – hence my hunch that this problem developed when installing Swiftweasel)there, and not mozilla-thunderbird, this may help.  The more complex solutions suggested in various forums may not be needed and did not work for me.

    I run Ubuntu 7.10 Gutsy Gibbon 64-bit with 32-bit Firefox, and now, joyfully, Swiftweasel, its soooo much faster.

    Here is the technique I used to make mailto links point from Swiftweasel and Firefox to Thunderbird – it is in part borrowed from fixes reported in various forums.

    1) Launch Swiftweasel or Firefox and view the configuration strings using the URL
    about:config

    2) using the field at the top, search for
       mailto

    3) If you do NOT have network.protocol-handler.app.mailto (normally
    you don't), create it using these steps:
      a) right-click
      b) choose New --> String
      c) new string: network.protocol-handler.app.mailto
      d) new value: /usr/bin/thunderbird

    4) If you already see an entry for
    network.protocol-handler.app.mailto, verify the path to the mail
    client. Double click the string to set it if necessary. Also be sure
    network.protocol-handler.external.mailto is set to true

    5) Do the same in Firefox. Voila!  website links mailto: now launch Thunderbird.

    For the sake of curiosity, does anyone know if this was an update problem or a byproduct of the Swiftweasel installation? Or am I way off the mark? 

     
    • SticKK

      SticKK - 2007-11-23

      Swiftweasel and Firefox share no files at all, not even configuration or settings files. So if the links stopped working in Firefox it probably had nothing to do with installing Swiftweasel. But since they both share a common source code its possible both had a similar problem.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks