Crashes on right-click for Fonts directory

Anonymous
2016-11-03
2016-11-03
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2016-11-03

    Hi There. Still loving & using your program almost every day.

    Today I searched for a font, which it found. When I tried to right-click on the line so as to open the folder (C:\Windows\Fonts), it crashed, saiying SwiftSearch64{3CACE9B1-EF40-4a3b-B5E5-3... has stopped working"

    Only happened when I right-clik on a line for the Fonts direcotry - other folders worked OK.

     
    • Yosh Mantinband

      Yosh Mantinband - 2016-11-03

      (sorry, forgot to log in before posting. The crash report is from me.)

       
    •  

        - 2016-11-03

      Thanks for reporting!! So it looks like the issue is, as far as the shell is concerned, font files don't exist with their true file names... rather they exist with different names. So what ends up happening is that the path to the file fails to parse, and hence I pass a blank path to the context-menu function. I'm not exactly sure what the correct way to handle this should be... one option is to just disable right-click when the path parsing fails, but the user will have no idea what's going on. The other option is to special-case the Fonts folder, but it's bound to fail somewhere else again. The third option is to find a generic solution which I'm not aware of...

       


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks