Help save net neutrality! Learn more.

Crash on Save as... (version 0.9.3)

  • John Coppens

    John Coppens - 2009-12-03

    Hello people.

    Just compiled and installed version 0.9.3 (only needed to install the latest libsamplerate library). The program seemed to work fine - it loads files, selects, copies, plays correctly.

    When I copied a section, and 'Pasted as new', this worked fine too, but when doing a Save as…, using the WAV 16bit signed stereo format, Sweep just disappeared.

    On the console this message appeared:

    sweep: xcb_lock.c:33: _XCBUnlockDisplay: Assertion `xcb_get_request_sent(dpy->xcb->connection) == dpy->request' failed.

    This seems to be a 'classic', and can be solved by:

    export LIBXCB_ALLOW_SLOPPY_LOCK=true ; sweep

    A suggestion: I'd really appreciate a field indicating the length of the selection (preferably updated 'live', while selecting).


  • John Coppens

    John Coppens - 2009-12-05

    No, it's not solved - about 50% of the time, 'Save as…' kills sweep with the same error message.


Log in to post a comment.