Loading VMM

2011-10-25
2013-01-16
  • Andrew Elms

    Andrew Elms - 2011-10-25

    Has anyone had any success loading VMM into Eclipse/SVEditor?  I have tried several options for loading VMM, as a library and as a source collection and pointing to both the version that ships with VCS and the standalone version from VMM Central.

    No matter what, the vmm constructs are not getting recognized; `vmm_note, vmm_data, vmm_xactor, etc,

     
  • Matthew Ballance

    Have you tried creating a .f file that specifies the +incdir's for VMM and the source files you want to compile? That's what the VMM SVEditor tests do. For example, the .f file for the Ethernet example looks like this:

    +incdir+${VMM_HOME}/svv
    test_frame.sv
    test_mac.sv
    test_mii.sv
    top.sv

    Another thing to try is manually re-building the Indexes after changing the configuration: select a project in the Eclipse workspace, then right-click and select Rebuild Index from the context menu. This will force the index to be re-scanned.

     
  • Andrew Elms

    Andrew Elms - 2011-10-27

    Thanks for the suggestions, I have the VMM library sucessfully loaded in a windows (XP) installation of eclipse/sveditor.   The VMM library is under the project directory and is included in the manifest file with a relative path reference:

    Under linux (my real working environment) I have been having trouble.  My setup is a little different; VMM is installed outside the project.   I have a few things to try and will report back what worked (or ask for more help).

    Thanks for providing and supporting this project!

     
  • Matthew Ballance

    Hi Andrew,
        One suggestion is to use an environment variable to point to the VMM library. In the argument file:
    +incdir+${VMM_HOME}

    Regards,
    Matthew

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks