Wrong (random) metadata of mp3, ripped wit sr

  • Robin Kluth

    Robin Kluth - 2012-12-09


    I use streamripper to record a radio-event every friday night, I do that with that command:

    streamripper http://mp3.89.0rtl.de -a test.mp3 -l 14460 -A

    Since two weeks, I've experienced huge problems using streamripper :(

    I have randomly wrong metadata, sometimes its MPEG1 with 128 kbit, sometimes MPEG2 with 56 kbit, sometimes 300kbit, and so on.

    It randomly writing wrong bitrate/type to the file!

    At first, the basic things:

    Linux version 3.0.46-vs2. (root@build-squeeze.netcup.net) (gcc version 4.4.5 (Debian 4.4.5-8) ) #1 SMP Wed Oct 24 12:28:39 UTC 2012
    streamripper -v
    Streamripper 1.64.6

    What I've already tried is, to add these optional flags:

    --codeset-filesys=CP1252 --codeset-id3=CP1252 --codeset-metadata=CP1252 --codeset-relay=CP1252

    Nothing helped, yet :(

    Does anybody have an idea whats wrong?

  • Robin Kluth

    Robin Kluth - 2012-12-09

    I've placed two test-files on my webspace for review, if needed ;)

    File 1: http://dl.webcf.de/test%20%281%29.mp3
    File 2: http://dl.webcf.de/test%20%282%29.mp3

    Both created, using the same command (see above).

    Maybe the stream sends with VBR? Streamripper always (!) say this after fire it up:

    stream: 89.0 RTL
    server name: SHOUTcast/Linux v1.9.8
    declared bitrate: 128
    meta interval: 8192
    ^Ckipping...   ]  -  [    1kb]
  • Robin Kluth

    Robin Kluth - 2012-12-18

    Could do some more tests:

    Iam testing mplayer right now, which shall do the same task:
    It generates randomly damaged files, too!

    Now, I've figured it out (i think):

    Both programs are executed under a script, sample:

    streamripper *OPTS*

    this generates randomly damaged files, same thing with mplayer!

    So, if I use sh instead of bash, all is working fine!…???!

    If I run both programs directly in a shell (sh) all files are ok, same thing if I run this:

    streamripper *OPTS*

    root:# sh test.sh

    Why are the files damaged if running with bash and why they dont if I use sh?

    I only use bash, to get $RANDOM working, but I want to know if this is a common problem?

  • stoopidplox

    stoopidplox - 2012-12-22

    The files linked contain nothing but 128k MP3 frames and have no problems.

    What do you mean by "wrong metadata". Metadata is information about the stream name and song artist transmitted along with the stream, and is not part of the saved MP3. it has nothing to do with the bitrate or content of MP3 files that are saved (except for naming files if you use the option to split songs).


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks