Streamripper 1.64 GLIB >= 2.16.0

LarryJ
2009-11-12
2013-05-09
  • LarryJ

    LarryJ - 2009-11-12

    In Ubuntu 9.10 (2.6.31-14-generic)  ./configure in streamripper  1.64.6 fails complaining: "error: Glib 2.16 or greater required"

    According to Ubuntu's synaptic, I have  libglib2.0-0 is installed which is greater than 2.16.

    Is there way to fix this error so that  "configure" runs correctly?

     
  • xp99

    xp99 - 2009-11-13

    Actually that is version 2.0, so that is before 2.16.  Look for the version 2.16 or greater for Ubuntu 9.10.

     
  • LarryJ

    LarryJ - 2009-11-13

    Sorry. Confusion on my part.   The Ubuntu Package is libglib2.0-0  but the version I have installed on the PC is   2.22.1-2.   So I'm still puzzled as why ./configure is urging  Glib greater than 2.16 when I have 2.22.1-2 which satisfies the condition.  

     
  • xp99

    xp99 - 2009-11-13

    Try doing a reinstall of the package.

     
  • LarryJ

    LarryJ - 2009-11-18

    More Noob stumbles:  Turns out I didn't have the development  files for the GLib library installed after all.   After I installed  libglib2.0-dev using Ubuntu's 9.10  Synaptic,  "./configure",  "make"  and "sudo make install" all ran without error.  "streamripper -v" nows shows version 1.64.6 . My error was that  I saw  libglib2.0-0 listed in Synaptic  as installed then assumed that configure should be happy with it. Alas, configure was never happy!     I really should know better.  (:-{   Thanks for your help.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks