roysaty - 2009-06-22

Hello everyone,

I am developing using Visual Studio 2008 on Windows XP SP2.I am using an already developed set of libraries(lib & header files) developed using VS 2003.
In order to support multicompiler/multiplatform development I am using stlport.

Before using stlport in my project I was getting linking errors like this : 

DSP_Example1.obj : error LNK2019: unresolved external symbol "public: bool __thiscall dspDateSchedule::add(class std::vector<class dspDate,class std::allocator<class dspDate> > const &)" (?add@dspDateSchedule@@QAE_NABV?$vector@VdspDate@@V?$allocator@VdspDate@@@std@@@std@@@Z) referenced in function "public: class dspDateSchedule __thiscall dspDateSchedule::operator+(class dspDateSchedule const &)const " (??HdspDateSchedule@@QBE?AV0@ABV0@@Z)

After adding stlport to my project I am now getting linking errors like like the ones shown below.I have built stlport before using it in my project.

DSP_Example1.obj : error LNK2019: unresolved external symbol "public: bool __thiscall dspDateSchedule::add(class stlp_std::vector<class dspDate,class stlp_std::allocator<class dspDate> > const &)" (?add@dspDateSchedule@@QAE_NABV?$vector@VdspDate@@V?$allocator@VdspDate@@@stlp_std@@@stlp_std@@@Z) referenced in function "public: class dspDateSchedule __thiscall dspDateSchedule::operator+(class dspDateSchedule const &)const " (??HdspDateSchedule@@QBE?AV0@ABV0@@Z)

In additional include directories I have STLport-5.2.1\stlport in addition to the other header files that I am using.

In additional library directories I have STLport-5.2.1\lib.
In additional dependencies I have my original libraries compiled using VS 2003 in addition to the stlport libraries. 

Any suggestions on what may be going wrong ? 

Thanks in advance. 

Regards,

SR