On Mon, Sep 16, 2013 at 6:12 AM, Barry Gerdes <barrygastro@hotmail.com> wrote:
I have managed to get a compile of 6273 that runs. (Well sort of)
The most noticable problem is there are no stars. The log says access to the catalogues denied.
There is no splash screen.  However startup is almost instantaneous
Without the stars The frame rate  is around 220fps on my XP build
I have built with Qtcreator and Msys, same results
I have a problem with Qtcreator in XP, It takes about two minutes to load.
With Windows 8 Qtcreator loads within 3 seconds
Compile is successful but still no stars or splash Frame rate 155fps
Msys same result.

If the star catalogs are not loaded, it's normal that you are getting very fast loading times and very high frame rates. :)

I am not getting that far. Stellarium crashes with the following assertion failure in the log:

Loading star data ...

ASSERT: "sizeof(Star1) == 28" in file D:\stellarium\simplegles-qml\src\core\modules\ZoneArray.cpp, line 180

Some debugging shows that the size of Star1 is 32. Looking at the code, it looks like there may be some problems with the compiler or its flags on Windows.