Cannot Run Stellarium In Fullscreen

Feedback
Anonymous
2014-08-28
2014-08-28
  • Anonymous - 2014-08-28

    Stellarium 0.12.4
    elementary OS "Luna" (Ubuntu 12.04 LTS)
    AMD Radeon HD 7770

    I cannot run Stellarium in fullscreen mode. I had to edit the config file to set fullscreen to false and it works, but if I hit F11 it crashes Stellarium. I believe this may be due to using a proprietary driver (ATI/AMD proprietary FGLRX graphics driver). I have to use this driver or everything else on my computer is too small to use as the default (I guess open-source) driver does not support the screen resolution I like to run on my 22" Acer monitor which is 1440x900.

     
  • Alexander Wolf

    Alexander Wolf - 2014-08-28

    It can be related to drivers. Can you show log.txt and crash dump (or trace)?

     
  • Anonymous - 2014-08-28

    I forgot to mention the default resolution, 1680x1050, which makes everything else too small to use.

    Using the proprietary driver for the video card and using 1680x1050, Stellarium crashes when going to full screen just like it does when using 1440x900.

    Using the open-source Radeon driver supplied by Ubuntu, Stellarium works fine in fullscreen.

    I take this to mean Stellarium needs to support closed-source AMD video card drivers.

     
  • Anonymous - 2014-08-28

    Here is log.txt but I see no error(s). I hit F11 which makes it go fullscreen and shows nothing. I hit F11 again after about 10 seconds or so which returned it to a smaller screen showing everything Stellarium should be showing:

    2014-08-28T01:40:41
    Linux version 3.2.0-67-generic (buildd@brownie) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #101-Ubuntu SMP Tue Jul 15 17:46:11 UTC 2014
    Compiled using GCC 4.6.3
    Qt runtime version: 4.8.1
    Qt compilation version: 4.8.1
    Addressing mode: 64-bit
    MemTotal: 12302988 kB
    MemFree: 4839508 kB
    SwapTotal: 12573692 kB
    model name : AMD Phenom(tm) II X6 1090T Processor
    cpu MHz : 3200.000
    model name : AMD Phenom(tm) II X6 1090T Processor
    cpu MHz : 800.000
    model name : AMD Phenom(tm) II X6 1090T Processor
    cpu MHz : 800.000
    model name : AMD Phenom(tm) II X6 1090T Processor
    cpu MHz : 800.000
    model name : AMD Phenom(tm) II X6 1090T Processor
    cpu MHz : 800.000
    model name : AMD Phenom(tm) II X6 1090T Processor
    cpu MHz : 800.000
    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde XT [Radeon HD 7770 GHz Edition] (prog-if 00 [VGA controller])
    Kernel driver in use: fglrx_pci
    Kernel modules: fglrx
    stellarium


    [ This is Stellarium 0.12.4 - http://www.stellarium.org ]
    [ Copyright (C) 2000-2013 Fabien Chereau et al ]


    Writing log file to: "/home/owner/.stellarium/log.txt"
    File search paths:
    0 . "/home/owner/.stellarium"
    1 . "/usr/share/stellarium"
    Attempting to use an existing older config file.
    Config file is: "/home/owner/.stellarium/config.ini"
    Going to initialize the OpenGL 2 renderer
    OpenGL supported version: "4.2.12337 Compatibility Profile Context 13.101"
    Qt GL paint engine is: "OpenGL2"
    GL vendor is "ATI Technologies Inc."
    GL renderer is "AMD Radeon HD 7700 Series"
    Log of the compilation of builtin shader " plainShader " : "Built successfully"
    Log of the compilation of builtin shader " colorShader " : "Built successfully"
    Log of the compilation of builtin shader " textureShader " : "Built successfully"
    Log of the compilation of builtin shader " colorTextureShader " : "Built successfully"
    Cache directory is: "/home/owner/.cache/stellarium/stellarium"
    Sky language is "en_US"
    Application language is "en_US"
    Loading Solar System data ...
    Loaded 63 / 63 planet orbits from "/home/owner/.stellarium/data/ssystem.ini"
    Loading star data ...
    "Loading "/usr/share/stellarium/stars/default/stars_0_0v0_3.cat": 0_0v0_2; 4963"
    "Loading "/usr/share/stellarium/stars/default/stars_1_0v0_3.cat": 1_0v0_2; 21598"
    "Loading "/usr/share/stellarium/stars/default/stars_2_0v0_3.cat": 2_0v0_2; 150090"
    "Loading "/usr/share/stellarium/stars/default/stars_3_1v0_2.cat": 3_1v0_1; 423540"
    "Loading "/home/owner/.stellarium/stars/default/stars_4_1v0_0.cat": 4_1v0_0; 1725497"
    "Loading "/home/owner/.stellarium/stars/default/stars_5_2v0_0.cat": 5_2v0_0; 7669011"
    "Loading "/home/owner/.stellarium/stars/default/stars_6_2v0_0.cat": 6_2v0_0; 26615233"
    "Loading "/home/owner/.stellarium/stars/default/stars_7_2v0_0.cat": 7_2v0_0; 57826266"
    "Loading "/home/owner/.stellarium/stars/default/stars_8_2v0_0.cat": 8_2v0_0; 116923084"
    Finished loading star catalogue data, max_geodesic_level: 8
    navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
    Loaded 10051 NGC records
    Loading NGC name data ...
    Loaded 412 / 412 NGC name records successfully
    Loading star names from "/usr/share/stellarium/skycultures/western/star_names.fab"
    Loaded 236 / 236 common star names
    Loading star names from "/usr/share/stellarium/stars/default/name.fab"
    Loaded 4359 / 4359 scientific star names
    Loading variable stars from "/usr/share/stellarium/stars/default/gcvs_hip_part.dat"
    Loaded 6886 / 6886 variable stars
    Loaded 88 / 88 constellation records successfully for culture "western"
    Loaded 85 / 85 constellation art records successfully for culture "western"
    Loaded 89 / 89 constellation names
    Loading constellation boundary data ...
    Loaded 782 constellation boundary segments
    Not using any viewport effect
    Creating GUI ...
    Loading shortcuts...
    Can't find plugin with id "RendererStatistics"
    Can't find plugin with id "RendererStatistics"
    Loaded plugin "Oculars" .
    Ocular plugin - press Command-O to toggle eyepiece view mode. Press ALT-o for configuration.
    Oculars::validateIniFile ocular.ini exists at: "/home/owner/.stellarium/modules/Oculars/ocular.ini" . Checking version...
    Oculars::validateIniFile found existing ini file version 2
    Loaded plugin "Satellites" .
    Satellites: loading catalog file: "/home/owner/.stellarium/modules/Satellites/satellites.json"
    Loaded plugin "SolarSystemEditor" .
    Using the ssystem.ini file that already exists in the user directory...
    Loaded plugin "TimeZoneConfiguration" .
    Simple planet shader build log: "Built successfully"
    Shadow planet shader build log: "Built successfully"
    Using vertex shader for atmosphere rendering.
    Atmosphere shader build log: "Built successfully"
    Build log after adding a Mat4d transform shader: "Built successfully"
    Build log after adding a stereographic projection shader: "Built successfully"

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks