Problems with custom landscapes

Feedback
Paul Walsh
2012-08-13
2012-10-09
  • Paul Walsh

    Paul Walsh - 2012-08-13

    Last year I generated a panorama of our Astro Society dark site. it's
    2048x1024 in size and I'm able to load it into Stellarium on Linux without
    problem. However, if I transfer the files to a Windows 7 virtual machine, when
    I try loading the landscape I just get a white screen (I get the same effect
    with Mars and Moon landscapes - depending on date/time setting in Stellarium).
    The landscape.ini file contains:

    [landscape]
    name = broadacres
    type = spherical
    maptex = broad5.png
    angle_rotatez = 73
    

    I then thought I'd try an "old style" landscape so created 4 1024x512 "sides"
    and a 512x512 ground with the following landscape.ini

    [landscape]
    name = darksite
    author = Paul Walsh
    description = Dark site
    type = old_style
    nbsidetex = 4
    tex0 = broad-a1.png
    tex1 = broad-a2.png
    tex2 = broad-a3.png
    tex3 = broad-a4.png
    nbside = 4
    side0 = tex0:0:0.005:1:1
    side1 = tex1:0:0.005:1:1
    side2 = tex2:0:0.005:1:1
    side3 = tex3:0:0.005:1:1
    groundtex = broadacres-gnd-512.png
    ground = groundtex:0:0:1:1
    
    [location]
    planet = Earth
    latitude = +47d40'44"
    longitude = -123d30'41"
    altitude = 1597
    

    Unfortunately, this causes Stellarium to crash in Linux and Windows.

    Has anyone experienced similar issues?

    Paul

     
  • barrykgerdes

    barrykgerdes - 2012-08-13

    Hi

    The display of Spherical landscapes in Stellarium depends a lot on how much
    video memory is available. I don't know what virtual program you are using but
    it probably has not allocated enough memory to the video. I use VMware 8.04 in
    Windows 7 running Ubuntu 12.04 as a virtual and it will run the 2048 x 1024
    spherical landscapes but not 4096 x 2048. It has no problem running a 10 panel
    old type landscape with 10 1024 x 1024 panels.

    The problem you are having with your old type landscape will be syntax in the
    ini file.

    It should look like this

    name = English Garden
    author = Robert Spearman (Digitalis)
    description = The English Garden, Munich, Germany.\nApril 24, 2007.\nMade with
    assistance from Johan Meuris
    type = old_style
    nbsidetex = 4
    tex0 = egarden-22.png
    tex1 = egarden-33.png
    tex2 = egarden-44.png
    tex3 = egarden-11.png
    nbside = 4
    side0 = tex1:0:0.00:1:1
    side1 = tex2:0:0.00:1:1
    side2 = tex3:0:0.00:1:1
    side3 = tex0:0:0.00:1:1
    groundtex = egardenb.png
    ground = groundtex:0:0:1:1
    fogtex = fogridge.png
    fog = fogtex:0:0:1:1
    nb_decor_repeat = 1
    decor_alt_angle = 55
    decor_angle_shift = -21
    decor_angle_rotatez = 90
    ground_angle_shift = -16
    ground_angle_rotatez = -41
    fog_alt_angle = 20
    fog_angle_shift = -3
    draw_ground_first = 1

    tan_mode = true

    planet = Earth
    latitude = +48d15'36"
    longitude = +11d40'15"
    altitude = 443

    Barry

     
  • barrykgerdes

    barrykgerdes - 2012-08-13

    Further

    The panels in the old style landscapes need to be square for best results else
    you may have trouble with aspect.

    Barry

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks