0.13.0 ugly font

Feedback
gammaburst
2014-07-20
2014-08-03
  • gammaburst

    gammaburst - 2014-07-20

    I updated from 0.12.4 to 0.13.0 and now the object info text font (and the toolbar font) is ugly and somewhat hard to read. The new font is lighter weight (thinner strokes) than 0.12.4, and diagonal strokes such as 'X' are too faint. Is anyone else seeing this problem? I'm running 32-bit Stellarium on Win7 SP1 64-bit, i7, and GTX 460 with driver 337.88.

    I have screen snapshots, but I don't see how to attach them to this message.

     
    • Alexander Wolf

      Alexander Wolf - 2014-07-20

      Look at "Add attachments" link near "Post Reply" button

       
  • gammaburst

    gammaburst - 2014-07-20

    Ahh, hiding in plain sight.
    Here are similar views using 0.12.4 and 0.13.0.

     
  • Anonymous - 2014-07-21

    Hi,

    the same (and even worse) here. Windows 7 64 bit

     
  • Anonymous - 2014-07-23

    edit to my last post: the wrong fonts-display occurs allways, no matter which font I select in the config.ini.

    (Windows 7 64 bit, NVIDIA Geforce GT 240M, Driver-Version 327.02)

    For the screenshot I enlarged the fontsize to make it easier to see the problem.

     
  • gammaburst

    gammaburst - 2014-07-25

    I just updated my old WinXP machine from Stellarium 0.12.4 to 0.13.0, and now I'm seeing the same ugly object info font as 0.13.0.png above, and also the corrupt star name font as Bild1.PNG above. The system has WinXP SP3 32-bit, two quad-core Xeon CPUs, GeForce 9600GT with driver 275.33.

     
  • Anonymous - 2014-07-26

    I found a solutiun for this problems: download the version with MESA (stellarium-0.13.0-MESA-win32.exe) from https://launchpad.net/stellarium/+download

    Stellarium will work MUCH slower with this version, but after 10 minutes you got used to it.

     
  • gammaburst

    gammaburst - 2014-07-28

    Funny! I was just about to write a similar message. I tried to install 0.13.0 onto my old ASUS Eee PC 1005HA WinXP netbook. That didn't work because 0.13.0 requires OpenGL 2.1, and ASUS hasn't updated its graphics driver since OpenGL 1.4. I installed MESA, and the fonts look great. That little computer gives only 5 FPS maximum at full CPU usage. To conserve battery power, I reduced minimum_fps to 2 in config.ini. That's pretty slow, but ok for my outdoor use.

     
  • gammaburst

    gammaburst - 2014-07-31

    Does 0.13.0 provide any adjustments for font type, line width, anti-aliasing, or gamma? Such settings would probably affect the ugly font. I looked in config.ini but didn't see anything obvious.

    In Win7 I can make the 0.13.0 object info font look good by increasing NVIDIA's gamma setting to maximum, but that of course makes everything else on the screen look awful. The gamma setting is located in NVIDIA Control Panel > Display > Adjust desktop color settings > Use NVIDIA settings > Gamma.

     
    Last edit: gammaburst 2014-07-31
    • Alexander Wolf

      Alexander Wolf - 2014-07-31

      Does 0.13.0 provide any adjustments for font type, line width, anti-aliasing, or gamma?

      Stellarium uses operating system settings for fonts, exclude font name and font size - those parameters you can set in config.ini (gui/base_font_size & gui/base_font_name)

       
      Last edit: Alexander Wolf 2014-07-31
      • gammaburst

        gammaburst - 2014-08-01

        I tried fiddling with most of the 3D settings in NVIDIA Control Panel, but nothing seems to affect the ugly font rendering. Yes I clicked Apply and restarted Stellarium after each experiment.

        There is no gui/base_font_name in config.ini, so I added it, set it to a random non-existent name, and now the toolbar text and most of the object info text look very good. I think it's Arial Regular 10 point, and NOT anti-aliased so it's nice and sharp. However the phrase "variable star" and the magnitude value use some bold anti-aliased font, so the ugly problem still affects them.

        I tried setting base_font_name to a valid path/filename, but I'm still seeing the same Arial. Don't know why that didn't work. There's no error/warning in log.txt.

         
        Last edit: gammaburst 2014-08-01
        • Alexander Wolf

          Alexander Wolf - 2014-08-01

          You can add:
          [gui]
          base_font_name = Arial Regular
          base_font_file = Arial.ttf

           
          • gammaburst

            gammaburst - 2014-08-01

            That works, thanks. Looks like I can specify either base_font_name or base_font_file, I don't need both.

            Do you know which font Stellarium is trying to display (in Win7) when those config.ini variables aren't set? I tried deleting Stellarium's two DejaVuSans*.tff files, but that didn't seem to affect anything.

             
            • Alexander Wolf

              Alexander Wolf - 2014-08-01

              He's should be DejaVu Sans by default. If font can't be found then Windows will be substitute it. In series 0.12 we used Verdana for Windows by default - you can try it too.

               
  • gammaburst

    gammaburst - 2014-08-01

    If 0.13.0 uses DejaVu Sans by default, then deleting the DejaVu*.ttf files should have had some effect, but it didn't. Maybe my Stellarium somehow isn't finding its own DejaVu files?

    I just discovered this combination works quite well for me. It avoids most of the troublesome anti-aliasing:
    [gui]
    base_font_name = MS Sans Serif
    base_font_size = 13

     
  • gammaburst

    gammaburst - 2014-08-03

    I may have found the Windows settings that directly affect this problem.

    If I disable ClearType and enable "smooth edges of screen fonts" in Win7, or if I set "use the following method to smooth edges of screen fonts" to "Standard" in WinXP, then I see the ugly font shown in my example "font 0.13.0.png".

    If I disable "use the following method to smooth edges of screen fonts" in WinXP, then I see the corrupt font shown in Anonymous's examples "Stellarium.jpg" and "Bild1.PNG". I haven't yet reproduced this corruption in Win7.

    I don't like ClearType's color fringing effect, so I will keep it disabled and continue using my MS Sans Serif workaround in Stellarium.

    Developers: Please make Stellarium's fonts readable for all ClearType and screen font smoothing settings.

     
    • Alexander Wolf

      Alexander Wolf - 2014-08-03

      Please try use Verdana ;)

       
      • gammaburst

        gammaburst - 2014-08-03

        Verdana was my second choice after MS Sans Serif. Both behave similarly during my tests. Most other fonts have anti-aliasing, which is troublesome.

        That "Stellarium.jpg" and "Bild1.PNG" corruption is intermittent in my WinXP. I rebooted and now the corruption occurs even when I disable "use the following method to smooth edges of screen fonts". The corruption messes up the bottom few rows of pixels. It resembles a too-small memory buffer, but that's just a wild guess.

         


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks