Crash at startup

Feedback
Anonymous
2014-08-27
2014-09-08
  • Anonymous - 2014-08-27

    I installed stellarium 12.4 from the repo on ubuntu 14.04

    However it crashes with the following output (CLI)

    Any support will be appreciated.

    thanks

    boss@boss-laptop:~$ stellarium
    Using default graphics system specified at build time: raster


    [ This is Stellarium 0.12.4 - http://www.stellarium.org ]
    [ Copyright (C) 2000-2013 Fabien Chereau et al ]


    Writing log file to: "/home/boss/.stellarium/log.txt"
    File search paths:
    0 . "/home/boss/.stellarium"
    1 . "/usr/share/stellarium"
    Attempting to use an existing older config file.
    Config file is: "/home/boss/.stellarium/config.ini"
    Going to initialize the OpenGL 2 renderer
    OpenGL supported version: "1.4 Mesa 10.1.3"
    Qt GL paint engine is: "OpenGL"
    StelQGL2Renderer::init : Failed because Qt paint engine is not OpenGL2
    If paint engine is OpenGL3 or higher, this code needs to be updated
    Failed to initialize the OpenGL 2 renderer, falling back to the OpenGL 1 renderer
    OpenGL supported version: "1.4 Mesa 10.1.3"
    Qt GL paint engine is: "OpenGL"
    GL vendor is "Intel Open Source Technology Center"
    GL renderer is "Mesa DRI Intel(R) 945GM x86/MMX/SSE2"
    WARNING : Couldn't find texture file "textures/logo24bits.png" : ""
    createTextureBackend failed: file " "textures/logo24bits.png" " not found.
    Error occured during loading of texture "" : "loadFromImage(): Image data to load from is null. Maybe the image failed to load from file?"
    Cache directory is: "/home/boss/.cache/stellarium/stellarium"
    Sky language is "en_US"
    Application language is "en_US"
    Loading Solar System data ...
    Loaded 88 / 88 planet orbits from "/usr/share/stellarium/data/ssystem.ini"
    Found an old starsConfig.json file, upgrade..
    Creates file "/home/boss/.stellarium/stars/default/starsConfig.json"
    Loading star data ...
    "Loading "/usr/share/stellarium/stars/default/stars_0_0v0_5.cat": 0_0v0_2; 4963"
    "Loading "/usr/share/stellarium/stars/default/stars_1_0v0_5.cat": 1_0v0_2; 21598"
    "Loading "/usr/share/stellarium/stars/default/stars_2_0v0_5.cat": 2_0v0_2; 150090"
    "Loading "/usr/share/stellarium/stars/default/stars_3_1v0_3.cat": 3_1v0_3; 428466"
    Finished loading star catalogue data, max_geodesic_level: 3
    navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
    Loaded 10051 NGC records
    Loading NGC name data ...
    Loaded 416 / 416 NGC name records successfully
    Loading star names from "/usr/share/stellarium/skycultures/western/star_names.fab"
    Loaded 237 / 237 common star names
    Loading star names from "/usr/share/stellarium/stars/default/name.fab"
    Loaded 4359 / 4359 scientific star names
    Loading variable stars from "/usr/share/stellarium/stars/default/gcvs_hip_part.dat"
    Loaded 6886 / 6886 variable stars
    Loaded 88 / 88 constellation records successfully for culture "western"
    Loaded 85 / 85 constellation art records successfully for culture "western"
    Loaded 89 / 89 constellation names
    Loading constellation boundary data ...
    Loaded 782 constellation boundary segments
    Not using any viewport effect
    Creating GUI ...
    Loading shortcuts...
    shortcuts.json doesn't exist, copying default...
    Creating file "/home/boss/.stellarium/data/shortcuts.json"
    Could not create shortcuts file data/shortcuts.json. Error: file not found: data/default_shortcuts.json
    Couldn't copy default shortcuts file, shortcuts aren't loaded
    Implicitly creating group "Windows" for action "actionShow_ScriptConsole_Window_Global" ; group text is empty
    Can't find action "actionQuit_Global"
    QObject::connect: Cannot connect (null)::triggered() to StelGui::quit()
    Can't find action "actionShow_Constellation_Lines"
    Segmentation fault (core dumped)
    boss@boss-laptop:~$

     
  • Alexander Wolf

    Alexander Wolf - 2014-08-27

    You really need install stellarium-data also

     
  • Anonymous - 2014-08-28

    Thanks for the assistance Alexander. stellarium-data was already installed however remove/install worked.

     
    • Alexander Wolf

      Alexander Wolf - 2014-08-28

      Is it was very old package?

       
  • Anonymous - 2014-08-28

    Well don't think so. Two days ago I removed a working 12.4 and installed 13 from stellarium website. It had opengl problem so I removed that and installed 12.4 from repo again. After that it crashed on startup.

     
  • Alexander Wolf

    Alexander Wolf - 2014-08-28

    Oh, it was super new package! :)

     
  • gzotti

    gzotti - 2014-09-08

    OpenGL supported version: "1.4 Mesa 10.1.3"

    You therefore also need updated OpenGL drivers, be that new MESA or real ones.

    You can start V0.12 still in "safe" mode on the current setup. For V0.13 you need OpenGL2.1 with GLSL1.3 support.

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks