Version 12 and older dates

Feedback
Anonymous
2013-03-13
2013-03-14
  • Anonymous - 2013-03-13

    I uninstalled 12.0 and reinstalled 11.4 and my script below runs correctly when it doesn't run correctly in 12.0. When I run it the date and time come up -2-09-01 and the time is 3:00:00. This is with an offset of plus 2. When I ran the same script in 12.0 it came up -2-08-01 and I think about 16:00:00 for the time. Something happened between 11.4 and 12.0 to cause Stellarium to change the dates in my script that results in a different date and time. Thanks for any help you can provide.

    Here is some setup script in my script:

    / Setup display mode
    core.setObserverLocation(0.0, 0.0, 0.0, 1.0, "", "Earth");
    core.clear("natural");
    core.setProjectionMode("ProjectionPerspective");
    LandscapeMgr.setCurrentLandscapeName("Mars");
    LandscapeMgr.setFlagCardinalsPoints(true);
    ConstellationMgr.setFlagArt(false);
    ConstellationMgr.setFlagLines(false);
    ConstellationMgr.setFlagLabels(false);
    SolarSystem.setFlagPlanets(true);
    SolarSystem.setFlagLabels(true);
    SolarSystem.setFlagTrails(true);
    StarMgr.setFlagLabels(true);
    core.setSelectedObjectInfo ("None");

    core.setDate("-2:09:01T1:00:00");
    core.setObserverLocation(44.33, 26.19, 00, 01, "Bagdad, Iraq");
    core.moveToAltAzi(60, 90, 3);
    core.selectObjectByName("Jupiter");
    StelMovementMgr.setFlagTracking(true);
    StelMovementMgr.zoomTo(30);

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks