Stellarium 0.15.1 crashes on startup

  • Victor Abeloff

    Victor Abeloff - 2016-12-28

    On Windows 10 Pro buld 1607 with NVidia GeForce GTX 980 video card running driver version 376.33. Stellarium 0.15.0 runs smoothly on the same system.

    Faulting application name: stellarium.exe, version:, time stamp: 0x585fa5da
    Faulting module name: MSVCR120.dll, version: 12.0.21005.1, time stamp: 0x524f83ff
    Exception code: 0xc0000409
    Fault offset: 0x0000000000074a30
    Faulting process id: 0x2b58
    Faulting application start time: 0x01d26163092ff0b7
    Faulting application path: C:\Program Files\Stellarium\stellarium.exe
    Faulting module path: C:\WINDOWS\SYSTEM32\MSVCR120.dll
    Report Id: fe8832aa-62d2-4f12-9288-5f930cd09977
    Faulting package full name:
    Faulting package-relative application ID:

    • Alexander Wolf

      Alexander Wolf - 2016-12-29

      Are you have Intel graphics card on this computer also?

      • Victor Abeloff

        Victor Abeloff - 2016-12-29

        not that I am aware of

  • Comment has been marked as spam. 

    You can see all pending comments posted by this user  here

    Anonymous - 2016-12-29

    I am getting the same problem (same exception code and fault offset) - 64bit Windows 10 Pro installation, Intel Core i7-3770 CPU @ 3.4GHz, ATI FirePro V4800 Graphics adaptor (driver 15.201.1151.1008), 32Gb RAM.

    This is a first time installation - I have no history with 0.15.0.

  • Comment has been marked as spam. 

    You can see all pending comments posted by this user  here

    Anonymous - 2016-12-30

    Since upgrading from 64-bit Stellarium 0.15.0 on Windows 10 Pro 64-bit to Stellarium 0.15.1, Stellarium frequently crashes when I start it. This didn't happen when I used 0.15.0. I have a NVIDIA GeForce GT 630 graphics card with the latest drivers installed (

  • Comment has been marked as spam. 

    You can see all pending comments posted by this user  here

    Anonymous - 2016-12-30

    STellarium 0.15.1 64 bit crashes hard on win 10 EVERY time you zoom in tigher than a 5.82 degree FOV... Is that perhaps where the Tycho catalog tries to bring in the next set of stars? In an effort to see if I could 'run over' the problem with an update I tried to download catalog 7 and it said it couldnt find it. This was an attempt to FIX the crash... But it didnt work.

    I currently cannot use Stellarium because I must zoom in farther for purposes of doing my talks around the country and I cant have the program crash because I didnt notice how much I was zooming. I have the latest NVidia drivers and a good graphics card that has no issues with any other program.. So magic 8 ball says, "all signs point to bug in Stellarium"...

    Is there a way to remove the extra star catalogs? This would test the problem in part.

    Marc Dantonio
    FX Models/Trumbull Studios

    • gzotti

      gzotti - 2016-12-30

      There was a change in the star catalogs, and I had such a "zoom to 5° crash" during development. Extra stars should be in C:/Users/YOU/AppData/Roaming/Stellarium/stars/default. Simply rename default and try again please. If this helps, delete the renamed folder and re-download the updated catalogs. (A new folder "default" will be created on launch.)

      • Comment has been marked as spam. 

        You can see all pending comments posted by this user  here

        Anonymous - 2016-12-30

        Ok thanks I will try it and let you know... in the meantime I installed the 32 bit version which runs fine.
        On another note: 1: The star catalog download no longer works within STellarium. The files are not at the location expected so there are no additional catalogs to download.
        2: Can I have the 32 bit version and 64 bit versions installed simultaneiously or do I have to uninstall the 32 bit and reinstall the 64 bit? I am not sure this will work but you will certainly know.

        • gzotti

          gzotti - 2016-12-30
          1. See other thread
          2. You can have many installations, as long as they are in different directories.32/64 are usually separate, but you may want to rename folders and program groups during installation to know which is which.
  • Alexander Wolf

    Alexander Wolf - 2016-12-30

    Anybody had info in log.txt after crash?

  • Comment has been marked as spam. 

    You can see all pending comments posted by this user  here

    Anonymous - 2016-12-30

    Overwritten when I went back to 015.0. So, in trying to help diagnose I tried 0.15.1 again. No explanation; however, this time 0.15.1 runs without crashing. In addition to shutting down and restarting the system, Microsoft Visual Studio 2010 Tools for Office Runtime (x64) was installed yesterday (behind the scenes).

  • Comment has been marked as spam. 

    You can see all pending comments posted by this user  here

    Anonymous - 2016-12-30

    MAc 15.1 crashes on start up > log .txt

    Unsupported Mac version
    Compiled using Clang 5.0.0
    Qt runtime version: 5.6.2
    Qt compilation version: 5.6.2
    Addressing mode: 64-bit
    Model Name: MacBook Pro
    Model Identifier: MacBookPro11,3
    Processor Name: Intel Core i7
    Processor Speed: 2.5 GHz
    Number of Processors: 1
    Memory: 16 GB
    Chipset Model: Intel Iris Pro
    VRAM (Dynamic, Max): 1536 MB
    Chipset Model: NVIDIA GeForce GT 750M
    VRAM (Total): 2048 MB

    [ This is Stellarium 0.15.1 - ]
    [ Copyright (C) 2000-2016 Fabien Chereau et al. ]

    Writing log file to: "/Users/GVC/Library/Application Support/Stellarium/log.txt"
    File search paths:
    0 . "/Users/GVC/Library/Application Support/Stellarium"
    1 . "/private/var/folders/6m/c553pw3s7rzbrkmg3n7v8jwc0000gn/T/AppTranslocation/F204FAFB-9404-42A1-B838-A2426A607E2D/d/"
    Attempting to use an existing older config file.
    Clear cache and update config.ini...
    Config file is: "/Users/GVC/Library/Application Support/Stellarium/config.ini"
    Driver version string: "2.1 NVIDIA-10.14.20 355.10.05.15f03"
    GL vendor is "NVIDIA Corporation"
    GL renderer is "NVIDIA GeForce GT 750M OpenGL Engine"
    GL Shading Language version is "1.20"
    Cache directory is: "/Users/GVC/Library/Caches/stellarium/stellarium"
    Sky language is "en_US"
    Application language is "en_US"
    Loading Solar System data ...
    Loading star data ...
    "Loading \"/private/var/folders/6m/c553pw3s7rzbrkmg3n7v8jwc0000gn/T/AppTranslocation/F204FAFB-9404-42A1-B838-A2426A607E2D/d/\": 0_0v0_7; 4979"
    "Loading \"/private/var/folders/6m/c553pw3s7rzbrkmg3n7v8jwc0000gn/T/AppTranslocation/F204FAFB-9404-42A1-B838-A2426A607E2D/d/\": 1_0v0_7; 21806"
    "Loading \"/private/var/folders/6m/c553pw3s7rzbrkmg3n7v8jwc0000gn/T/AppTranslocation/F204FAFB-9404-42A1-B838-A2426A607E2D/d/\": 2_0v0_7; 150850"
    "Loading \"/private/var/folders/6m/c553pw3s7rzbrkmg3n7v8jwc0000gn/T/AppTranslocation/F204FAFB-9404-42A1-B838-A2426A607E2D/d/\": 3_1v0_4; 425807"
    Finished loading star catalogue data, max_geodesic_level: 3
    navigation/preset_sky_time is a double - treating as jday: "2451514.25001"
    Reloading DSO data...
    Loaded 10757 DSO records
    ERROR parsing landscape.ini file: ""
    Unknown landscape type: " "" "
    No valid landscape definition (no name) found for landscape ID "STRJordonView1" . No landscape in use.

    Landscape type mismatch for landscape "STRJordonView1" , expected fisheye, found "" . No landscape in use.

    Invalid sky culture directory: "dendera"
    Initializing basic GL shaders...
    Creating GUI ...

    Steve Raymond

    • gzotti

      gzotti - 2016-12-30

      () ERROR parsing landscape.ini file: "" + 3 lines
      ) Invalid sky culture directory: "dendera"
      Can you rename your config.ini to force default config with default landscape and default skyculture?

  • qam1

    qam1 - 2016-12-31

    You could always try turning some of the plug ins off. Especially the satillite one which is a big memory/cpu hog.

    For me, with the satillite plug in turned on, Stellarium will run choppy and freeze & crash, but after I edited the config.ini to not to load it at startup and close & re-start Stellarium it runs fine. I don't care about man made satilites so I'm not missing anything.

    I disable the load at startup of all plug ins and automatic updates except Angle Measurment & Solar System Editor just to be on the safe side. If I need/want any of them I manually turn them on individually.

    Last edit: qam1 2016-12-31
  • Patrick

    Patrick - 2017-01-08

    I am having similar issues to some of the other users in this thread. This is my first time installing/attempting to run Stellarium, so I am not sure what to look at next. Upon startup I see the Stellarium splash screen for a couple of seconds, then get a standard Windows application crash dialog ("Stellarium has stopped working..."). Here are my log and config:

    Run Log

    Relevant Windows Event Log Entry


    Things I have tried:

    Installing/running both the 32/64 bit versions
    Running Stellarium in "normal" mode, ANGLE mode, and MESA mode
    I have disabled all plugins except Angle measurement and Solar System Editor
    Disabled all automatic update in config.ini

    Regardless of these changes, I get the exact same result using any combination of the above configurations.

    2 things that stick out to me:

    The Windows event log entry regarding regarding MSCVR120.dll

    Line 64 of the run log - Loaded 279 / 405 DSO name records successfully (This is the only "loaded x / y records" log entry where the x and y are not the same)

    As I said, I have never run Stellarium before so I am unsure where to go from here. Any help would be greatly appreciated.

  • gzotti

    gzotti - 2017-01-08

    Strange. Can you try to install and run 0.15.0, and then 0.15.1? ( Install to a different directory, and use a different program group name, so you can have both versions. To reset, delete config.ini and/or the stars folder in C:\Users\YOU\AppData\Roaming\Stellarium.

    • Patrick

      Patrick - 2017-01-09

      I installed 15.0 to another directory as requested. During the install, I left all of the options alone, allowing it to delete/recreate the relevant config files. First run produced a different result.

      Unable to find module called "TimeZoneConfiguration"
      Full Log

      I had never seen this error before. I thought we may be onto to something, but even after disabling all of the plugins it still failed to start. Full log for that run

      This time I get the same partial DSO load issue, but different counts. 221 / 297 this time.

      Still getting the same MSVCR120.dll error in the Windows event logs as well.

      Running version 15.1.1 again after installing running 15.0 produces the same behavior as before.

      Last edit: Patrick 2017-01-09


Cancel  Add attachments

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks