11.3 dmg update for OSX

1 2 > >> (Page 1 of 2)
  • Anonymous

    Anonymous - 2012-06-14

    When will the .dmg update download for OSX be released?

  • Anonymous

    Anonymous - 2012-06-23

    Thank you for all of the most informative and beneficial reply's? NONE! Whats
    up with this site?

  • Argon

    Argon - 2012-06-26

    Would also be interested to know what the holdup is on this?

  • barrykgerdes

    barrykgerdes - 2012-06-27

    The lack of a "dmg" build for the later versions of Stellarium is regrettable
    however as the compilation of distribution packages for the various platforms
    is done on a voluntary basis by developers when they are able.

    If you would like the latest version available at any time you should try
    compiling it yourself. There is an instruction in the wiki on the programs you
    need to install as dependencies and once this is set up compiling the latest
    version can be done on a daily basis with very little effort.


  • Argon

    Argon - 2012-06-29

    So why does the page state that the package will be launched "on the next

    Many who use Stellarium are not in a position to "compile it yourself" as has
    been suggested.

    A simple polite update on the likely realease date would be helpful.


  • The Alchymist's Laboratory

    Have compiled stellarium some time ago on a Mac g4. Will have a go on iMac
    Intel os x 10.7.4. Most of pre-reqs installed now, although the downloadable
    bzar version was used as install via macports did not work. bzar then got
    stellarium source ok from command line. At the cmake config stage now, some
    errors to work through however.

  • The Alchymist's Laboratory

    Cmake giving error below on configuration - I assume a 'path' needs to be
    added to CMakeLists.txt ? Have not used this for some time.

    CMake Error at /Applications/CMake 2.8-8.app/Contents/share/cmake-2.8/Modules/
    FindPackageHandleStandardArgs.cmake:97 (MESSAGE):
    QT_QTCORE_LIBRARY) (Required is at least version "4.6.2")
    Call Stack (most recent call first):
    /Applications/CMake 2.8-8.app/Contents/share/cmake-2.8/Modules/FindPackageHand
    leStandardArgs.cmake:288 (_FPHSA_FAILURE_MESSAGE)
    CMakeLists.txt:245 (FIND_PACKAGE)

    Configuring incomplete, errors occurred!

  • RalphSBln

    RalphSBln - 2012-07-04

    P.S. please do not use the bug tracker for asking for an
    ETA/complaining/ranting/chatting or the like. Doing so will slow the devs down
    instead of speeding things up.

  • Anonymous

    Anonymous - 2012-07-18

    I can only ascertain that OSX users of Stellarium do not get any respect and
    are of little concern to the developers. Not sure in what way or how we OSX
    users have offended you, but please accept my apology and cease and desist
    your obvious neglect. Your actions are very curious and disconcerting. I look
    forward to installing, hopefully some time in the near future the Stellarium
    11.3 dmg update for OSX. Have a great day and good luck with what is seemingly
    the overwhelming problems involved with compiling an OSX 11.3 dmg. For us
    technically challenged users who enjoy and wish to use Stellarium.

  • barrykgerdes

    barrykgerdes - 2012-07-19

    Hi whitebuck777

    Stellarium is developed entirely by volunteers. If there are no OSX developers
    available to work on the problems there is nothing that can be done. If you
    would like a later version the source code is readily available for you to
    work on and produce your own version like other OSX users have done. I only
    work with Linux and Windows and do test compiles daily so I can't help.


  • Anonymous

    Anonymous - 2012-07-19

    Hello Barry

    Obviously as part of the OSX user community, I need to apologize for my
    misunderstood remark and for the scarcity of OSX users of Stellarium who have
    the time and skill with the desire to develop and compile an OSX 11.3 dmg. I
    unfortunately do not posses such skill. Maybe soon someone with the necessary
    attributes will join the Stellarium community. Thank goodness and the
    developers of OSX 11.2 dmg. that it is available and working. Your time and
    skill is greatly appreciated!

  • Skip Gaede

    Skip Gaede - 2012-07-26


    I'd like to help. I used the instructions on the wiki page "Compilation on
    Macosx." I installed macports, then cmake, qt4-mac, and bzr. I skipped
    building the dependencies for carbon. I then downloaded the source (bzr branch
    lp:stellarium stellarium), setup the build directory structure, did the cmake,
    make and make install. All went as expected.

    When I tried make macosx_bundle, I got the following:

    skip-OSX:macosx sgaede$ make macosx_bundle
    make: No rule to make target CMakeFiles/install.dir/all', needed byCMakeFiles/macosx_bundle.dir/all'. Stop.
    Error 2
    make: *** Error 2

    I found a thread in the pub-devel archive on 2012-04-15 on the same topic. The
    fix described there wasn't applicable because the makefile no longer contains
    the relevant text.

    If anyone has suggestions, I'm all ears.


  • Skip Gaede

    Skip Gaede - 2012-07-27

    In #14 skipgaede reported finding the same problem. After doing some
    investigating, I found two problems that had to be fixed, and a third one that
    was eliminated by starting with a clean install of Lion.

    Problem #1:

    make: *** No rule to make target CMakeFiles/install.dir/all', needed byCMakeFiles/macosx_bundle.dir/all'. Stop.

    The source of this error is in stellarium/builds/macosx/CMakeFiles/Makefile2
    on line 137:

    CMakeFiles/macosx_bundle.dir/all: CMakeFiles/install.dir/all

    The dependency doesn't exist. Edit the line and remove everything to the right
    of the colon.
    This edit should be done before issuing the command

    "sudo make macosx_bundle" (elevated priviledges are needed to read the
    dynamically linked library headers.)

    Problem #2:

    There are two copies of libiconv.2.dylib on the system. One (the "bad" one) is
    located in /usr/lib/, and the other ("good" one) is located in /opt/local/lib.
    While creating the bundle, the bad version is selected. If you try launching
    the app before fixing it, you will get an error report:

    Dyld Error Message:
    Library not loaded: @executable_path/../Frameworks/x86_64/libiconv.2.dylib
    Referenced from: /Users/USER/*/Stellarium.app/Contents/MacOS/../Frameworks/x86
    Reason: Incompatible library version: libintl.8.dylib requires version 8.0.0
    or later, but libiconv.2.dylib provides version 7.0.0

    We need to replace the incorrect version with the correct one:

    In the finder window, navigate to the macosx build directory, right click on
    the Stellarium app, and choose "Show Package Contents." Navigate to
    Contents/Frameworks/x86_64/ and delete libiconv.2.dylib. Open a second finder
    window, click on the Go menu item and choose "Go to Folder" (Shift-Command-G).
    Type in /opt<enter> and navigate to /opt/local/lib. Select libiconv.2.dylib,
    right click and pick "copy." Click on the other finder window and, in the
    x86_64 folder, paste the copied library.

    Problem fixed, at least it was on my clean install. On my working copy of
    Lion, I had another slight glitch: There was an older version of Qt installed.
    I found an uninstall python script in /Developer/Tools/uninstall_qt.py. Had I
    discovered this before installing the new version, it probably would have
    worked out better.

    I'm not the first person who's bumped up against this libiconv library
    incompatibility. See this discussion...


    I'm sure, now that the problem and a fix have been identified, that a better
    solution exists. Let's hope so, anyway.


  • Timothy Reaves

    Timothy Reaves - 2012-07-28

    The problem with the 'official' Applue build was my laptop; even though it is
    an Intel Core2Duo, it was the first model, and even with a 64bit CPU, it
    reports an arch of i386. So when I would go to bundle, the arch of the actual
    app would not match. I now have a new machine - MacBook Retina - that does not
    have this issue. It builds a bundle just fine. However, it is Mountain Lion.

    I've just uploaded a test DMG to

    This is a trunk build, and, will probably only work on Mountain Lion. Please
    test it, and let me know if it works. If it does, I'll get a FireWire drive,
    and install 10.6, and will use the Snow Leopard for the official builds.

  • Anonymous

    Anonymous - 2012-07-28

    Hello treaves, I have SL, so unfortunately unable to help, hopefully someone
    will answers your request with ML installed, soon. Thank you for your time and
    effort and good luck!

  • Argon

    Argon - 2012-07-28

    All seems to work except that cmd Q freezes my MBP running Mountain Lion.
    Selecting quit from the menu works fine though.
    Other than that, can't find any other problems, so job well done :)

  • Anonymous

    Anonymous - 2012-07-29

    I just downloaded and installed Stellarium 0.11.3 dmg / 0.11.4 on screen, to
    all who helped in the development and compilation of OSX .dmg update, I offer
    a thank you, for your time, expertise and energies are greatly appreciated!

  • RalphSBln

    RalphSBln - 2012-07-30

    Thanks for the official build!

    But the changes from rev 5457 do not seem to be embodied in this build? The QT
    plugin libs are still in sub folders under MacOS rather than in their own flat
    plugins directory.

    Okay unless the Qt framework is installed on the system (if Qt is installed
    Stellarium will crash on startup).

  • Timothy Reaves

    Timothy Reaves - 2012-07-30

    This was what was taged as 0.11.3, which was several weeks old. I'll look at
    that revision you mention tonight.

  • M.Evans

    M.Evans - 2012-07-30

    I have been waiting for Stellarium 0.11.3 Mac version for months. Now that
    it's finally here, it says it's for Mac OSX 10.6+. Has Leopard support been
    dropped? If so, why is there no mention anywhere of dropping support? It
    would have been nice if it was at least mentioned somewhere. It's like a slap
    to the face after waiting so long.

  • Timothy Reaves

    Timothy Reaves - 2012-07-30

    Um, it says "10.6+". That directly implies that support for Leopard has been
    dropped. So it was mentioned.

    Stellarium will still run on 10.5, but you need to build it yourself. With the
    entire PPC/PPC64/Intel32/Intel64 but Apple forces i386/Intel64 and the
    Carbon/Cocoa crap, we just do not have the hardware, the time, or the
    volenteers to do it. It is unfortunate that we can not put out a Universal
    app, but, as we're cmake based due to the cross platform nature of the app, it
    isn't going to happen.

  • M.Evans

    M.Evans - 2012-07-30

    "Um, it says "10.6+". That directly implies that support for Leopard has been
    dropped. So it was mentioned."

    Thanks for that annoying comment. I did see that, but that was only put
    there today! Before that, it said "10.5+". There should have been something
    in the 0.11.2 release notes that said "This is the final version to support
    OSX 10.5 Leopard & PPC." Then people would know that it's the last version
    instead of waiting for months to find out suddenly.

1 2 > >> (Page 1 of 2)

Log in to post a comment.