Windows build

  • MarionY

    MarionY - 2007-09-15

    I am trying to set up a windows build environment and (thought) I followed the instructions. I get to the cmake command in msys and it fails because it says the g++ complier is broken. I have reinstalled it several times already. Right now I have it in c:\mingw, path is set to c:\mingw\bin, and I have a fstab in msys\1.0\ect pointing msys\1.0\mingw to it. When I installed mingw in msys, then cmake couldn't find it. There is also a g++ in Dev-Cpp but it doesn't seem to look there. I added Dev-Cpp to the MSYS environment PATH command, but it still doesn't look there. Any suggestions would be greatly appreciated.

    Also, I got the development version from SVN. It has the cmakelists. I was going to practice compiling with it. But I really want to work with 8.2. I got 8.2 from cvs, but it does not have the cmake files. I can see v8 in SVN but I don't know how to check it out.
    Thanks again,

    • Matthew Gates

      Matthew Gates - 2007-09-15

      The 0.8.x series builds using autotools - automake, autoconf and friends. The build process on Windows using the autotools is not known to me - I have only ever used autotools on *nix systems (I only recently set up a Windows build environment). Older version of the wiki page might help - look under the history for that page.

      Using "which cmake", "which g++", "g++ --version" and so on, here's what I find in my MSYS build environment:

      cmake is found at: /c/Program Files/CMake 2.4/bin/cmake
      cmake version is 2.4-patch6

      g++ is found at: /mingw/bin/g++
      g++ version is g++.exe (GCC) 3.4.2 (mingw-special)

      make is found at: /bin/make
      make has version: 3.79.

      What is the exact message you see which tells you g++ is broken?


      • MarionY

        MarionY - 2007-09-15

        Thank you for reply.

        I have c:/Cmake 2.4/bin/cmake
        version 2.4 patch5

        There are two g++
        this one is version 3.4.2-20040916
        In c:/msys/1.0/mingw there is nothing.
        I uninstalled minGW from C; and reinstalled to c:/msys/1.0/mingw but got essentailly the same error message. I can try it again.

        I am sorry. Perhaps I made a mess of all the installations. Am willing to start over.

        There is a make at

        Here is the error:
        cmake -G "MSYS Makefiles" ../..
        -- Check for working C compiler: /MinGW/bin/gcc.exe
        -- Check for working C compiler: /MinGW/bin/gcc.exe -- broken
        CMake Error: The C compiler "/MinGW/bin/gcc.exe" is not able to compile a simple test program.
        It fails with the following output:
        /usr/bin/make -f CMakeFiles/cmTryCompileExec.dir/build.make CMakeFiles/cmTryCom pileExec.dir/build
        make[1]: Entering directory /usr/home/Administrator/stellarium9/builds/msys/CMa keFiles/CMakeTmp' /c/CMake\ 2.4/bin/cmake.exe -E cmake_progress_report /C/msys/1.0/home/Administra tor/stellarium9/builds/msys/CMakeFiles/CMakeTmp/CMakeFiles 1 Building C object CMakeFiles/cmTryCompileExec.dir/testCCompiler.obj /MinGW/bin/gcc.exe -o CMakeFiles/cmTryCompileExec.dir/testCCompiler.obj -c / C/msys/1.0/home/Administrator/stellarium9/builds/msys/CMakeFiles/CMakeTmp/testCC ompiler.c /bin/sh: /MinGW/bin/gcc.exe: No such file or directory make[1]: Leaving directory/usr/home/Administrator/stellarium9/builds/msys/CMak eFiles/CMakeTmp'
        make[1]: [CMakeFiles/cmTryCompileExec.dir/testCCompiler.obj] Error 127
        [cmTryCompileExec/fast] Error 2

        • Matthew Gates

          Matthew Gates - 2007-09-15

          I think this is the key line:

          /bin/sh: /MinGW/bin/gcc.exe: No such file or directory

          This makes me think the mingw installation is not healthy for some reason. I didn't install MinGW myself - I let the QT 4.3.0 installer do it for me. I don't know if that is helpful.


    • MarionY

      MarionY - 2007-09-15

      This is what I have in msys\1.0\etc\fstab
      c:/mingw /mingw
      c:/ActiveState/perl /perl

      I thought this would point to C:/mingw.

    • MarionY

      MarionY - 2007-09-15

      Ok - Thanks. I'll try to get Qt to load mingw.

  • Anonymous - 2014-05-13

    This is my error, who can help me to fix it

  • barrykgerdes

    barrykgerdes - 2014-05-13

    This thread is obsolete. What do you want to build? Instructions for making a build environment are in the wiki. If you want to build with msys and mingw use the 32 bit build. The current source for version 0.13.0 works well once you have all the dependencies, about a 2GB download!


    Last edit: barrykgerdes 2014-05-13


Cancel  Add attachments