Why is the timezone correct but the view of the sky not matching that time...?

Feedback
Anonymous
2013-11-20
2016-04-22
  • Anonymous - 2013-11-20

    I have used Stellarium on and off for quite some time. I have never had any problem with the program correctly displaying the sky for the proper time of day. But now I do. I am running a simulation for MY location. My computer clock says 14:10 (i.e. 2:10PM) and Stellarium is dutifully picking that time up and also displays 14:10. But what I see on the screen is a bunch of stars, as if it is nighttime! I have to advance the clock to MIDNIGHT to get the sunrise. It is totally out of whack between what the screen displays and what the program clock says the time is. I downloaded the most recent version and tried again...same deal. Anyone have any clue what might be happening? NOTE: This is not a mismatch between my system clock and Stellarium...they both agree. It is a mismatch between the Stellarium clock and what is actually happening in the sky!

     
  • barrykgerdes

    barrykgerdes - 2013-11-21

    I assume you are using version 0.12.4. You need to select your location and save it then set your computer clock to the local time/date and tick or un-tick Daylight saving as it applies. I have no trouble setting the time in Stellarium to correspond to the actual views.

    Barry

     
  • Anonymous - 2013-11-22

    Yes, I installed 0.12.4 and the views used to match up perfectly with what you would expect to see as compared to the system clock. Now it is like 12 hours off!
    I am going to attach some pics:
    1 = my system clock, showing it is set for Eastern U.S. (I live near Cincinnati, OH)
    2 = Stellarium location setting, showing I have picked Cincinnati OH USA
    3 = Stellarium clock, showing it has correctly picked up my system timezone and time
    4 = The CURRENT view of my location as of right now... which about Noon on 11/22/13. Note the stars! It thinks it is the middle of the night! (I do not have atmosphere turned off!)
    5 = The view of my location if I pump the clock up to about Midnight... the SUN has risen!

    Something is way off in the sync between location and clock (the clock in the program itself). Any ideas?

     
  • Anonymous - 2013-11-27

    Does anyone have any clue what is going on?

     
  • Martin Lewicki

    Martin Lewicki - 2013-11-28

    Try this.

    go to - "Configuration"
    then - "Plugins"
    then - "Time zone" in the left column.
    click - "Configure" at bottom right'

    Check that radio button "Use system settings (default)" is ON.

     
    • Anonymous - 2014-04-04

      Não deu certo! valeu.

       
  • Anonymous - 2013-11-30

    Bingo! I actually had the Time Zone Plugin turned off, and I assumed it would revert to the default value of Local System timezone. But apparently not (might be a big worth looking into for future releases, actually). Instead, Stellarium was picking up an old setting of UTC-10 (vs. the true local of UTC-5), making everything look 5 hours out of sync. Anyway, fixed now but certainly worth a look for the programmers. The intuitive response to this PlugIn being off would be to revert to the Local System value. Thanks!

     
  • Bogdan Marinov

    Bogdan Marinov - 2013-12-01

    The Time Zone plug-in is just an graphical interface for editing an obscure feature of Stellarium's main configuration file. Even if you turn off the plug-in, the changes to config.ini remain in force, as you found out.

     
    • Anonymous - 2014-02-03

      I too have a problem where the actual sky outside my window does not match what appears on my screen. I have done that stuff with the plug-ins, as stated above, but my display is still incorrect. For example, right now the moon is shown as being at an elevation of 25 degrees yet outside my window (I can see it as I write, just under the top of the window) it is more like fifty, maybe fifty five degrees! What's wrong? I have entered my location and altitude very carefully... HELP!

       
  • Anonymous - 2014-03-06

    Check you have the right time zone on your PC .

     
  • Anonymous - 2014-04-08

    Olá pessoal também estou com este problema e não achei a solução já tentei de tudo, mas nada. se alguém puder me ajudar eu agradeço. O meu céu não condiz com o céu real local. Saudações a todos.

     
  • Patrick Koehn

    Patrick Koehn - 2016-04-20

    I am having the same problem(ish). When I first start Stellarium, all is as it should be. In a script I set the location and time:

    core.setObserverLocation(98.4936, 29.4241, 1, 1, "San Antonio, Texas", "Earth");
    core.wait(1);
    core.setDate("2016-03-19T00:00:00", "utc");

    I have tried "local" as well.

    Once the script runs, the Sun is up and where is should be in 12 hours. The clock reads 00:00:00.

    I have checked my system's time, date and time zone, activated the Time Zone plug-in and set it there. My hunch is that it is the setDate command, but it seems pretty straightforward to me.

    Any suggestions?

     
  • gzotti

    gzotti - 2016-04-20

    Have you restarted Stellarium after setting time zone with the TZ plugin?

     
  • Patrick Koehn

    Patrick Koehn - 2016-04-21

    I have. What is odd to me is that this happens under both Windows 10 and OSX (10.recent), so I have to think it is someting I'm missing about the setDate command, or something subtle about how Stellarium handles time.

    I should have mentioned before, I'm running v0.14.3 of Stellarium.

    Thanks for reading,

    PLK

     
  • gzotti

    gzotti - 2016-04-21

    Your Longitude has the wrong sign!

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2016-04-22

    Oh, man. Facepalm time.

    Thank you. I really appreciate your response, and I hope you didn't waste time on my question.

    PLK

     
    • waldo kitty

      waldo kitty - 2016-04-22

      On 04/21/2016 09:06 PM, noreply@in.sf.net wrote:

      Oh, man. Facepalm time.

      Thank you. I really appreciate your response, and I hope you didn't waste
      time on my question.

      i'm, astonished that you didn't see it when looking at the map when setting the
      location... the location marker would have been off from where you expected it
      to be...

       
  • Patrick Koehn

    Patrick Koehn - 2016-04-22

    It was set in a script so there was no map. Just a dumb mistake.

     
    • waldo kitty

      waldo kitty - 2016-04-22

      On 04/22/2016 07:53 AM, Patrick Koehn wrote:

      It was set in a script so there was no map. Just a dumb mistake.

      oh! ok... i missed that it was in a script... i've done similar things myself ;)

       


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks