Error running gap5 after compiling from current SVN

2013-11-01
2013-11-07
  • Sven Klages

    Sven Klages - 2013-11-01

    Hi,
    today I compiled io_lib and staden from current SVN and ran into trouble when executing gap5 (gap4 seems to run just fine):

    load libgap5.so => couldn't load file "libgap5.so": /package/sequencer/StadenPackage/current/bin/../lib/staden/libgap5.so: undefined symbol: scram_put_seq
    invalid command name "load_alignment_matrix"
    while executing
    "load_alignment_matrix       [keylget gap5_defs ALIGNMENT.MATRIX_FILE]"
    (file "/package/sequencer/StadenPackage/current/bin/../share/staden/tcl/gap5/gap5.tcl" line 675)
    

    Any idea what is going wrong here?

    thanks, Sven

     
  • Sven Klages

    Sven Klages - 2013-11-04

    Same error when using tg_index to convert SAM to gap5:

    xxx.sam
    tg_index.bin: symbol lookup error: /package/sequencer/StadenPackage/svn_2013-11-01/lib/staden/libgap5.so: undefined symbol: scram_open

     
  • Sven Klages

    Sven Klages - 2013-11-04

    Problem solved. There was a wrong (custom) LD_LIBRARY_PATH set pointing to an old installation of io_lib :-(

    Sorry for the noise ..

     
  • James Bonfield

    James Bonfield - 2013-11-07

    No problem - it's no noise at all since SourceForge stopped notifying us of any discussions or bug reports. I wish I knew how to reenable these, other than the really obvious email subscription feature which doesn't do anything. Grr

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks