Pregap4 not filling .exp files

  • Christy Cross

    Christy Cross - 2010-08-13

    For some reason, whenever I try to run pregap4 (on Windows, v1.7) it finishes, but everything fails because "Initialize Experiment Files" didn't fill the file with any line items. The modules selected being General configuration, Estimate Base Accuracies, Initialize Experiment Files, Augment Experiment Files, and Quality Clip (and I've also tried it with Phred instead of 'Estimate…')

    Sometimes when I open the .exp file there will be three line items (TN PR and CH) but they are from the next step "Augment Experiment Files" therefore all the other steps, like "Quality Clip" don't work.

    Is there a way to get this working, other than reinstalling? (I'm assuming its not just a setting)

  • James Bonfield

    James Bonfield - 2010-08-18

    This sounds like the "init_exp" program is failing for some reason. Unfortunately I don't have the tools (or time) currently to work on the Windows version, although I plan on obtaining a windows development box sometime soon so I can start porting Gap5.

    You could try running init_exp on the command line to see what happens. It takes a trace file as an argument. Do any of the pregap4 log or error files contain useful data too?

  • Nobody/Anonymous

    I'm not sure if 'init_exp" is completely failing, as the .exp file is created it is just not adding in the lines it is supposed to. So the error message I get is from Quality Clip later on as it cannot read the experiment file.

    However if the phredpar.dat file does not exist and the PHRED_PARAMETER_FILE variable is not present, "init_exp" works just fine. The readout just gives a warning from the Phred report that the 'chemistry' could not be found or something. It still calls the bases and gives a usable .exp file.

    How important is the chemistry to Phred? In the Ubuntu version of staden that I run (the newest version), if the parameter variable is not set, Phred wont run at all.


Log in to post a comment.