• Jake

    Jake - 2006-05-02

    I have a gap4 database with two contigs, each of them containing single trace. The traces are from the same template, one is forward, the other reverse read. While having one contig open in editor window I tried to open the other one in editor, upon which the gap4 terminated with the error message below.

    Jakub, WGRC, KSU

    snpworker@wgrc-th4307 /home/snp_project/SNP/KSU $ gap4
    load libcopy_reads.so =>
    load libitcl3.3.so =>
    load libitk3.3.so =>
    load libiwidgets.so => couldn't load file "libiwidgets.so": libiwidgets.so: cannot open shared object file: No such file or directory
    load libcap2.so =>
    load libcap3.so =>
    load libfak2.so =>
    load libphrap.so =>
    load libhaplo.so =>
    load libgap.so =>
    Level 2: init_editor_states .cedit14.0 .cedit14.0.seqs 0x8ba3a08
    Level 1: popup_cs_contig_1 1 .contig_sel.contig_sel 2 298
    Tue 02 May 13:34:24 2006 signal_handler: Program terminated unexpectedly with signal 11.
    Tue 02 May 13:34:24 2006 signal_handler: This is probably a bug.
    Tue 02 May 13:34:24 2006 signal_handler: Please report all bug reports at https://sourceforge.net/projects/staden/
    snpworker@wgrc-th4307 /home/snp_project/SNP/KSU $

    • Nobody/Anonymous

    • James Bonfield

      James Bonfield - 2006-05-19

      Is it possible to obtain a copy of this database? Say to jkb 'at' sanger.ac.uk?

      If it's a 100% reproducable bug then it's just the sort that can be fixed easily (generally) too.

      I know it's been ages since I've done gap4 updates - sorry for that but other work has taken precedence recently. However I'm still interested in fixing bugs obviously where they occur so that the next release will have them fixed.


    • Jake

      Jake - 2006-05-22

      I cannot submit the database on which I originally reported this, but recently I've got similar/same error message while trying to join two contigs. I can send you this one. It seems to be quite reproducible, though I didn't go over it enough times to claim it's 100%.
      I assume you will need also the traces? I'm asking, since it seems that when I've sent you data set last time it was too big to get through... (wish.exe on windows problem). Unless I hear from you, I'll send the whole thing, probably chopped into several emails.

      Speaking about wish.exe - I switched to Staden/Linux, and most of my databases ceased to have any problems, except few, which seemed to have a problem similar to the windows's "wish.exe" one. After automation of pregap4/gap4 assemblies I haven't noticed any further problems of this type. So maybe it was combination of me and certain type of data...


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks