staden1-0-6 and linux x86_64

2006-02-24
2013-04-18
  • Nobody/Anonymous

    Hi,
    has anyone build the source on an Intel x86_64 linux (SuSE 10 2.6.13-15-smp x86_64) machine?

    As root I then did
    cd src
    make -f Makefile.thirdparty
    which worked fine.

    I then cd.. and type 'make', still as root.

    After some progress, it aborts:

    make[2]: [read/linux-binaries/Read.o] Fehler 1 (ignoriert)
    gcc -g -DUSE_NON_CONST -DIOLIB_SCF -DIOLIB_EXP -DIOLIB_PLN -DIOLIB_ABI -DIOLIB_ALF -DIOLIB_CTF -DIOLIB_ZTR -DIOLIB_SFF -Iinclude -I. -I../Misc  -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wformat -Wstrict-prototypes -D_FILE_OFFSET_BITS=64 -fpic -I../zlib -o read/linux-binaries/Read.o -c read/linux-binaries/../Read.c
    read/linux-binaries/../Read.c:62:18: error: sff.h: Datei oder Verzeichnis nicht gefunden
    read/linux-binaries/../Read.c: In function ‘mfread_reading’:
    read/linux-binaries/../Read.c:181: warning: implicit declaration of function ‘mfread_sff’
    read/linux-binaries/../Read.c:181: warning: assignment makes pointer from integer without a cast
    make[2]: *** [read/linux-binaries/Read.o] Fehler 1
    make[2]: Leaving directory `/root/progs/staden-src-1-6-0/src/io_lib'
    make[1]: *** [io_lib] Fehler 2
    make[1]: Leaving directory `/root/progs/staden-src-1-6-0/src'
    make: *** [all] Fehler 2

    What compilation configuration did you have?  
    Thanks
    Michael

     
    • Nobody/Anonymous

      same error on fedora core 5. forced the $MACHINE to be linux, which i think is a big problem
      ooo maybe i need multilib, let me check
      thanks
      -Rohan

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks