building staden 2.0.0b1 on Mac OS X

2009-09-07
2013-04-18
  • Koen van der Drift

    Hi,

    I am trying to build Staden (latest sourcecode) on Mac OS X, but am getting stuck in the configure phase where it is trying to find all the tk/tcl related packages. I have installed all required packages using fink, and point the configure to the correct location, but still get errors:

    1. It finds the private headers in the build directory of tk/tcl:

    checking for Tcl private include files... Using -I"/sw/src/fink.build/tcltk-8.4.19-1/tcl8.4.19/generic" -I"/sw/src/fink.build/tcltk-8.4.19-1/tcl8.4.19/unix"
    checking for Tk private include files... Using -I"/sw/src/fink.build/tcltk-8.4.19-1/tk8.4.19/generic" -I"/sw/src/fink.build/tcltk-8.4.19-1/tk8.4.19/unix"

    even though these files have been deleted from my system

    2. it cannot find the tklib directory:

    checking tklib directory... no (/sw/lib/tklib0.4)
        /sw/lib/tklib0.4 is present

    3. it cannot find the iwidgets directory:
    checking iwidgets directory... no
          /sw/lib/iwidgets is present

    4. it cannot find the png files

    Is there any way that I can make Staden find these files, so I can successfully build the package?   I can attach the config.log for your reference, but didn't see a possibility to do so on this form.

     
    • James Bonfield

      James Bonfield - 2009-09-08

      Unfortunately attachements don't seem to be permitted by these web forums.

      In short though - I don't know what specific MacOS X problems there are as I haven't started targetting MacOS X yet as a build environment. Although it's worked in the past, that was before the major code reorganisation so I expect there will be some tweaks needed still.

      A few comments though found in experimenting on other systems.

      1. Unknown - I'm just using the tcl.m4 autoconf stub shipped with Tcl itself, which is horrendously complicated due to supporting normal unix layouts, windows, and MacOS X frameworks. I'm not sure why it doesn't work with your tcl setup.

      2. The checking tklib directory error was just a typo. It does find it, as is reported in brackets. Also fixed in SVN.

      3. The released source (fixed in SVN now) is a bit picky about the --with arguments. Itcl, Itk and Iwidgets all require the tcl package path directory *containing* the itcl*, itk* and iwidgets* subdirectories, rather than the full pathname to that directory itself. The next release will be more lenient, but for now try removing the last directory component from your (eg) --with-widgets=DIR option.

      4. What png files? Is this libpng you mean? It's a very minor feature and if it's still causing problems I could just make it optional so it continues to compile anyway. The only place I use libpng is in the html output from Gap4's "Report Mutations" function, which I'm not even sure works that well anyway.

      James

       
  • Nobody/Anonymous

    I also had similar problems with this version of staden on macosx (and have stuck to older versions). The first error message my system comes up with when trying to run gap4 is also about the lost iwidgets directory, which in my download appears as a dead link:

    /Users/db/bioapps/staden/macosx-bin/../lib/iwidgets ->
    /Users/jkb/staden-src-1-7-0/lib/iwidgets4.0.1

     
  • douda

    douda - 2009-09-16

    Replacing the dead link with the iwidgets directory from the macosx version of 1.6.0 (from staden-macosx-1-6-0.dmg) seems to fix the problem. A summary of my installation of staden-macosx-x86-1-7-0.tar.gz on macosx (assuming you have an older version at hand):

    \# unpack

    tar zxvf staden-macosx-x86-1-7-0.tar.gz

    \# move staden directory to where you want it to be

    mv macosx-rel-1-7-0/ ~/Public/bioapps/staden/

    \# edit your user profile (e.g. .bash_login) to add the following:

    export STADENROOT=/Users/douda/Public/bioapps/staden

    . $STADENROOT/staden.profile

    echo 'Setting up the Staden software environment…'

    \# copy an iwidgets directory over from a previous installation

    cp oldmacosx-rel-1-6-0/lib/iwidgets/ staden/lib/iwidgets/

    \# and it should be ready to run

    pregap4 &

    gap4 &

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks